Skip to content

← Actionable
Low, CVSS 2.7

Mattermost Fails to Check User Access to ExperimentalSettings

CVE-2025-2570GHSA-fpff-wj6m-grvr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.5.3, 9.11.12, 8.0.0-20250411064244-844447fbd57c), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-fpff-wj6m-grvr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =9.11.0 =0 <8.0.0-20250411064244-844447fbd57c

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-2570: 0.34% estimated exploitation activity in the next 30 days; percentile 27.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.5.x <= 10.5.2, 9.11.x <= 9.11.11 fail to check RestrictSystemAdmin setting if user doesn't have access to ExperimentalSettings which allows a System Manager to access ExperimentSettings when RestrictSystemAdmin is true via System Console.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fpff-wj6m-grvr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-2570

Advisory: Mattermost Fails to Check User Access to `ExperimentalSettings`
IDs: CVE-2025-2570, GHSA-fpff-wj6m-grvr
Record: https://patchnext.com/advisories/cve-2025-2570 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.5.3, 9.11.12, 8.0.0-20250411064244-844447fbd57c. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected >= 10.5.0, <= 10.5.2; >= 9.11.0, <= 9.11.11; < 8.0.0-20250411064244-844447fbd57c; fixed in 9.11.12, 8.0.0-20250411064244-844447fbd57c, 10.5.3

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fpff-wj6m-grvr (GitHub-reviewed advisory GHSA-fpff-wj6m-grvr lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =9.11.0 =0 <8.0.0-20250411064244-844447fbd57c)

Commands are suggestions: review each one before running it.

Loading voting…