Cross-site scripting (XSS) in the CKEditor 5 real-time collaboration package
CVE-2025-25299GHSA-j3mm-wmfm-mwvh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@ckeditor/ckeditor5-real-time-collaboration 44.2.1; ckeditor5-premium-features 44.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @ckeditor/ckeditor5-real-time-collaboration
- Affected
- >= 41.3.0, < 44.2.1
- Fixed in
- 44.2.1
npm ckeditor5-premium-features
- Affected
- >= 42.0.0, < 44.2.1
- Fixed in
- 44.2.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-j3mm-wmfm-mwvh lists affected ranges: npm @ckeditor/ckeditor5-real-time-collaboration >=41.3.0 =42.0.0 <44.2.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-25299: 0.60% estimated exploitation activity in the next 30 days; percentile 48.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact During a recent internal audit, we identified a Cross-Site Scripting (XSS) vulnerability in the CKEditor 5 real-time collaboration package. This vulnerability can lead to unauthorized JavaScript code execution and affects user markers, which represent users' positions within the document. This vulnerability affects only installations with Real-time collaborative editing enabled.
Patches The problem has been recognized and patched. The fix will be available in version 44.2.1 (and above).
For more information Email us at security@cksource.com if you have any questions or comments about this advisory.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-j3mm-wmfm-mwvh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25299 Advisory: Cross-site scripting (XSS) in the CKEditor 5 real-time collaboration package IDs: CVE-2025-25299, GHSA-j3mm-wmfm-mwvh Record: https://patchnext.com/advisories/cve-2025-25299 (revision 2, source checked 24 Oct 2026, 22:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @ckeditor/ckeditor5-real-time-collaboration 44.2.1; ckeditor5-premium-features 44.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @ckeditor/ckeditor5-real-time-collaboration: affected >= 41.3.0, < 44.2.1; fixed in 44.2.1 - npm ckeditor5-premium-features: affected >= 42.0.0, < 44.2.1; fixed in 44.2.1 ## Suggested inspection (read-only) - `npm ls @ckeditor/ckeditor5-real-time-collaboration --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls ckeditor5-premium-features --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @ckeditor/ckeditor5-real-time-collaboration, ckeditor5-premium-features. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-j3mm-wmfm-mwvh (OSV record GHSA-j3mm-wmfm-mwvh lists affected ranges: npm @ckeditor/ckeditor5-real-time-collaboration >=41.3.0 =42.0.0 <44.2.1 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…