Label Studio allows Cross-Site Scripting (XSS) via GET request to /projects/upload-example endpoint
CVE-2025-25296GHSA-wpq5-3366-mqw4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (label-studio 1.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI label-studio
- Affected
- < 1.16.0
- Fixed in
- 1.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-wpq5-3366-mqw4 lists affected ranges: PyPI label-studio >=0 <1.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wpq5-3366-mqw4 lists affected ranges: PyPI label-studio >=0 <1.16.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2025-25296: 1.90% estimated exploitation activity in the next 30 days; percentile 79.68 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description Label Studio's /projects/upload-example endpoint allows injection of arbitrary HTML through a GET request with an appropriately crafted labelconfig query parameter. By crafting a specially formatted XML label config with inline task data containing malicious HTML/JavaScript, an attacker can achieve Cross-Site Scripting (XSS). While the application has a Content Security Policy (CSP), it is only set in report-only mode, making it ineffective at preventing script execution. The vulnerability exists because the upload-example endpoint renders user-provided HTML content without proper sanitization on a GET request. This allows attackers to inject and execute arbitrary JavaScript in victims' browsers by getting them to visit a maliciously crafted URL. This is considered vulnerable because it enables attackers to execute JavaScript in victims' contexts, potentially allowing theft of sensitive data, session hijacking, or other malicious actions. Steps to reproduce 1. Create a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-wpq5-3366-mqw4
- Revision 1 · created ·
Published from osv record GHSA-wpq5-3366-mqw4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25296 Advisory: Label Studio allows Cross-Site Scripting (XSS) via GET request to `/projects/upload-example` endpoint IDs: CVE-2025-25296, GHSA-wpq5-3366-mqw4 Record: https://patchnext.com/advisories/cve-2025-25296 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: label-studio 1.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI label-studio: affected < 1.16.0; fixed in 1.16.0 ## Suggested inspection (read-only) - `python -m pip show label-studio`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on label-studio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-wpq5-3366-mqw4 (OSV record GHSA-wpq5-3366-mqw4 lists affected ranges: PyPI label-studio >=0 <1.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-wpq5-3366-mqw4 (GitHub-reviewed advisory GHSA-wpq5-3366-mqw4 lists affected ranges: PyPI label-studio >=0 <1.16.0) Commands are suggestions: review each one before running it.
Loading voting…