@octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
CVE-2025-25290GHSA-rmvr-2pp2-xj38
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@octokit/request 9.2.1, 8.4.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @octokit/request
- Affected
- >= 9.0.0-beta.1, < 9.2.1>= 1.0.0, < 8.4.1
- Fixed in
- 9.2.1, 8.4.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rmvr-2pp2-xj38 lists affected ranges: npm @octokit/request >=9.0.0-beta.1 =1.0.0 <8.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rmvr-2pp2-xj38 lists affected ranges: npm @octokit/request >=9.0.0-beta.1 =1.0.0 <8.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-25290: 0.78% estimated exploitation activity in the next 30 days; percentile 56.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The regular expression /<([^]+); rel="deprecation"/ used to match the link header in HTTP responses is vulnerable to a ReDoS (Regular Expression Denial of Service) attack. This vulnerability arises due to the unbounded nature of the regex's matching behavior, which can lead to catastrophic backtracking when processing specially crafted input. An attacker could exploit this flaw by sending a malicious link header, resulting in excessive CPU usage and potentially causing the server to become unresponsive, impacting service availability. Details The vulnerability resides in the regular expression /<([^]+); rel="deprecation"/, which is used to match the link header in HTTP responses. This regular expression captures content between angle brackets (<) followed by ; rel="deprecation". However, the pattern is vulnerable to ReDoS (Regular Expression Denial of Service) attacks due to its susceptibility to catastrophic backtracking when processing malicious input. An attacker can…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rmvr-2pp2-xj38
- Revision 1 · created ·
Published from osv record GHSA-rmvr-2pp2-xj38
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25290 Advisory: @octokit/request has a Regular Expression in fetchWrapper that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking IDs: CVE-2025-25290, GHSA-rmvr-2pp2-xj38 Record: https://patchnext.com/advisories/cve-2025-25290 (revision 2, source checked 26 Oct 2026, 12:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @octokit/request 9.2.1, 8.4.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @octokit/request: affected >= 9.0.0-beta.1, < 9.2.1; >= 1.0.0, < 8.4.1; fixed in 9.2.1, 8.4.1 ## Suggested inspection (read-only) - `npm ls @octokit/request --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @octokit/request. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rmvr-2pp2-xj38 (OSV record GHSA-rmvr-2pp2-xj38 lists affected ranges: npm @octokit/request >=9.0.0-beta.1 =1.0.0 <8.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-rmvr-2pp2-xj38 (GitHub-reviewed advisory GHSA-rmvr-2pp2-xj38 lists affected ranges: npm @octokit/request >=9.0.0-beta.1 =1.0.0 <8.4.1) Commands are suggestions: review each one before running it.
Loading voting…