Skip to content

← Actionable
Medium, CVSS 5.3amended

@octokit/plugin-paginate-rest has a Regular Expression in iterator Leads to ReDoS Vulnerability Due to Catastrophic Backtracking

CVE-2025-25288GHSA-h5c3-5r3r-rr8q

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@octokit/plugin-paginate-rest 11.4.1, 9.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-25288: 0.63% estimated exploitation activity in the next 30 days; percentile 50.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary For the npm package @octokit/plugin-paginate-rest, when calling octokit.paginate.iterator(), a specially crafted octokit instance—particularly with a malicious link parameter in the headers section of the request—can trigger a ReDoS attack. Details The issue occurs at line 39 of iterator.ts in the @octokit/plugin-paginate-rest repository. The relevant code is as follows: The regular expression /<([^]+);\srel="next"/ may lead to a potential backtracking vulnerability, resulting in a ReDoS (Regular Expression Denial of Service) attack. This could cause high CPU utilization and even service slowdowns or freezes when processing specially crafted Link headers. PoC The gist of PoC.js 1. run npm i @octokit/plugin-paginate-rest 2. run 'node poc.js' result: 3. then the program will stuck forever with high CPU usage Impact What kind of vulnerability is it? This is a Regular Expression Denial of Service (ReDoS) vulnerability, which occurs due to excessive backtracking in the regex…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-h5c3-5r3r-rr8q

  2. Revision 1 · created ·

    Published from osv record GHSA-h5c3-5r3r-rr8q

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-25288

Advisory: @octokit/plugin-paginate-rest has a Regular Expression in iterator Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
IDs: CVE-2025-25288, GHSA-h5c3-5r3r-rr8q
Record: https://patchnext.com/advisories/cve-2025-25288 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @octokit/plugin-paginate-rest 11.4.1, 9.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @octokit/plugin-paginate-rest: affected >= 9.3.0-beta.1, < 11.4.1; >= 1.0.0, < 9.2.2; fixed in 11.4.1, 9.2.2

## Suggested inspection (read-only)
- `npm ls @octokit/plugin-paginate-rest --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @octokit/plugin-paginate-rest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-h5c3-5r3r-rr8q (OSV record GHSA-h5c3-5r3r-rr8q lists affected ranges: npm @octokit/plugin-paginate-rest >=9.3.0-beta.1 =1.0.0 <9.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-h5c3-5r3r-rr8q (GitHub-reviewed advisory GHSA-h5c3-5r3r-rr8q lists affected ranges: npm @octokit/plugin-paginate-rest >=9.3.0-beta.1 =1.0.0 <9.2.2)

Commands are suggestions: review each one before running it.

Loading voting…