@octokit/endpoint has a Regular Expression in parse that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking
CVE-2025-25285GHSA-x4c5-c7rf-jjgv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@octokit/endpoint 10.1.3, 9.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 9.0.5, < 9.0.6>= 10.0.0, < 10.1.3
- Fixed in
- 10.1.3, 9.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x4c5-c7rf-jjgv lists affected ranges: npm @octokit/endpoint >=9.0.5 =10.0.0 <10.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x4c5-c7rf-jjgv lists affected ranges: npm @octokit/endpoint >=9.0.5 =10.0.0 <10.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2025-25285: 0.63% estimated exploitation activity in the next 30 days; percentile 50.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary By crafting specific options parameters, the endpoint.parse(options) call can be triggered, leading to a regular expression denial-of-service (ReDoS) attack. This causes the program to hang and results in high CPU utilization. Details The issue occurs in the parse function within the parse.ts file of the npm package @octokit/endpoint. The specific code is located at the following link: https://github.com/octokit/endpoint.js/blob/main/src/parse.ts, at line 62: The regular expression /[\w-]+(?=-preview)/g encounters a backtracking issue when it processes a large number of characters followed by the - symbol. e.g., the attack string: PoC The gist Here is the reproduction process for the vulnerability: 1. run npm i @octokit/endpoint 2. Move poc.js to the root directory of the same level as README.md 3. run node poc.js result: 4. then the program will be stuck forever with high CPU usage 1. Import the endpoint module: First, import the endpoint module from the npm package…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x4c5-c7rf-jjgv
- Revision 1 · created ·
Published from osv record GHSA-x4c5-c7rf-jjgv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25285 Advisory: @octokit/endpoint has a Regular Expression in parse that Leads to ReDoS Vulnerability Due to Catastrophic Backtracking IDs: CVE-2025-25285, GHSA-x4c5-c7rf-jjgv Record: https://patchnext.com/advisories/cve-2025-25285 (revision 2, source checked 26 Oct 2026, 12:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @octokit/endpoint 10.1.3, 9.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @octokit/endpoint: affected >= 9.0.5, < 9.0.6; >= 10.0.0, < 10.1.3; fixed in 10.1.3, 9.0.6 ## Suggested inspection (read-only) - `npm ls @octokit/endpoint --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @octokit/endpoint. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x4c5-c7rf-jjgv (OSV record GHSA-x4c5-c7rf-jjgv lists affected ranges: npm @octokit/endpoint >=9.0.5 =10.0.0 <10.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-x4c5-c7rf-jjgv (GitHub-reviewed advisory GHSA-x4c5-c7rf-jjgv lists affected ranges: npm @octokit/endpoint >=9.0.5 =10.0.0 <10.1.3) Commands are suggestions: review each one before running it.
Loading voting…