Skip to content

← Actionable
Critical, CVSS 9.9

Mattermost allows reading arbitrary files related to importing boards

CVE-2025-25279GHSA-5fwx-p6xh-vjrh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.4.2, 10.3.3, 10.2.3, 9.11.8, 8.0.0-20250122165010-4ed702ccff4e), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    < 8.0.0-20250122165010-4ed702ccff4e>= 9.11.0-rc1, < 9.11.8>= 10.2.0-rc1, < 10.2.3>= 10.3.0-rc1, < 10.3.3>= 10.4.0-rc1, < 10.4.2
    Fixed in
    8.0.0-20250122165010-4ed702ccff4e, 9.11.8, 10.3.3, 10.4.2, 10.2.3

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-5fwx-p6xh-vjrh lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =9.11.0-rc1 =10.2.0-rc1 =10.3.0-rc1 =10.4.0-rc1 <10.4.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-25279: 24.22% estimated exploitation activity in the next 30 days; percentile 97.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to properly validate board blocks when importing boards which allows an attacker could read any arbitrary file on the system via importing and exporting a specially crafted import archive in Boards.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5fwx-p6xh-vjrh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-25279

Advisory: Mattermost allows reading arbitrary files related to importing boards
IDs: CVE-2025-25279, GHSA-5fwx-p6xh-vjrh
Record: https://patchnext.com/advisories/cve-2025-25279 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.4.2, 10.3.3, 10.2.3, 9.11.8, 8.0.0-20250122165010-4ed702ccff4e. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250122165010-4ed702ccff4e; >= 9.11.0-rc1, < 9.11.8; >= 10.2.0-rc1, < 10.2.3; >= 10.3.0-rc1, < 10.3.3; >= 10.4.0-rc1, < 10.4.2; fixed in 8.0.0-20250122165010-4ed702ccff4e, 9.11.8, 10.3.3, 10.4.2, 10.2.3

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5fwx-p6xh-vjrh (GitHub-reviewed advisory GHSA-5fwx-p6xh-vjrh lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =9.11.0-rc1 =10.2.0-rc1 =10.3.0-rc1 =10.4.0-rc1 <10.4.2)

Commands are suggestions: review each one before running it.

Loading voting…