gh attestation verify returns incorrect exit code during verification if no attestations are present
CVE-2025-25204GHSA-fgw4-v983-mgp8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cli/cli/v2 2.67.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.49.0, < 2.67.0
- Fixed in
- 2.67.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fgw4-v983-mgp8 lists affected ranges: Go github.com/cli/cli/v2 >=2.49.0 <2.67.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2025-25204: 0.41% estimated exploitation activity in the next 30 days; percentile 34.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A bug in GitHub's Artifact Attestation CLI tool, gh attestation verify, may return an incorrect zero exit status when no matching attestations are found for the specified --predicate-type <value or the default https://slsa.dev/provenance/v1 if not specified. This issue only arises if an artifact has an attestation with a predicate type different from the one provided in the command. As a result, users relying solely on these exit codes may mistakenly believe the attestation has been verified, despite the absence of an attestation with the specified predicate type and the tool printing a verification failure. Users are advised to update gh to version v2.67.0 as soon as possible. Initial report: https://github.com/cli/cli/issues/10418 Fix: https://github.com/cli/cli/pull/10421 Details The gh attestation verify command fetches, loads, and attempts to verify attestations associated with a given artifact for a specified predicate type. If an attestation is found, but the predicate…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fgw4-v983-mgp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25204 Advisory: `gh attestation verify` returns incorrect exit code during verification if no attestations are present IDs: CVE-2025-25204, GHSA-fgw4-v983-mgp8 Record: https://patchnext.com/advisories/cve-2025-25204 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/cli/cli/v2 2.67.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/cli/cli/v2: affected >= 2.49.0, < 2.67.0; fixed in 2.67.0 ## Suggested inspection (read-only) - Go github.com/cli/cli/v2: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/cli/cli/v2. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fgw4-v983-mgp8 (GitHub-reviewed advisory GHSA-fgw4-v983-mgp8 lists affected ranges: Go github.com/cli/cli/v2 >=2.49.0 <2.67.0) Commands are suggestions: review each one before running it.
Loading voting…