Inefficient Regular Expression Complexity in koa
CVE-2025-25200GHSA-593f-38f6-jp5m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (koa 3.0.0-alpha.3, 2.15.4, 1.7.1, 0.21.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm koa
- Affected
- >= 2.0.0, < 2.15.4>= 3.0.0-alpha.0, < 3.0.0-alpha.3>= 1.0.0, < 1.7.1< 0.21.2
- Fixed in
- 1.7.1, 0.21.2, 3.0.0-alpha.3, 2.15.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-593f-38f6-jp5m lists affected ranges: npm koa >=2.0.0 =3.0.0-alpha.0 =1.0.0 =0 <0.21.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-593f-38f6-jp5m lists affected ranges: npm koa >=2.0.0 =3.0.0-alpha.0 =1.0.0 =0 <0.21.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H · score source
- EPSS
- CVE-2025-25200: 0.84% estimated exploitation activity in the next 30 days; percentile 57.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Koa uses an evil regex to parse the X-Forwarded-Proto and X-Forwarded-Host HTTP headers. This can be exploited to carry out a Denial-of-Service attack. PoC Coming soon. Impact This is a Regex Denial-of-Service attack and causes memory exhaustion. The regex should be improved and empty values should not be allowed.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-593f-38f6-jp5m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-593f-38f6-jp5m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25200 Advisory: Inefficient Regular Expression Complexity in koa IDs: CVE-2025-25200, GHSA-593f-38f6-jp5m Record: https://patchnext.com/advisories/cve-2025-25200 (revision 3, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: koa 3.0.0-alpha.3, 2.15.4, 1.7.1, 0.21.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm koa: affected >= 2.0.0, < 2.15.4; >= 3.0.0-alpha.0, < 3.0.0-alpha.3; >= 1.0.0, < 1.7.1; < 0.21.2; fixed in 1.7.1, 0.21.2, 3.0.0-alpha.3, 2.15.4 ## Suggested inspection (read-only) - `npm ls koa --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on koa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-593f-38f6-jp5m (OSV record GHSA-593f-38f6-jp5m lists affected ranges: npm koa >=2.0.0 =3.0.0-alpha.0 =1.0.0 =0 <0.21.2 (fixed)) - Verified: https://github.com/advisories/GHSA-593f-38f6-jp5m (GitHub-reviewed advisory GHSA-593f-38f6-jp5m lists affected ranges: npm koa >=2.0.0 =3.0.0-alpha.0 =1.0.0 =0 <0.21.2) Commands are suggestions: review each one before running it.
Loading voting…