Possible DoS by memory exhaustion in net-imap
CVE-2025-25186GHSA-7fc5-f82f-cx69
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net-imap 0.5.6, 0.4.19, 0.3.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems net-imap
- Affected
- >= 0.3.2, < 0.3.8>= 0.4.0, < 0.4.19>= 0.5.0, < 0.5.6
- Fixed in
- 0.4.19, 0.5.6, 0.3.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7fc5-f82f-cx69 lists affected ranges: RubyGems net-imap >=0.3.2 =0.4.0 =0.5.0 <0.5.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-25186: 0.63% estimated exploitation activity in the next 30 days; percentile 50.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary There is a possibility for denial of service by memory exhaustion in net-imap's response parser. At any time while the client is connected, a malicious server can send can send highly compressed uid-set data which is automatically read by the client's receiver thread. The response parser uses Range#toa to convert the uid-set data into arrays of integers, with no limitation on the expanded size of the ranges. Details IMAP's uid-set and sequence-set formats can compress ranges of numbers, for example: "1,2,3,4,5" and "1:5" both represent the same set. When Net::IMAP::ResponseParser receives APPENDUID or COPYUID response codes, it expands each uid-set into an array of integers. On a 64 bit system, these arrays will expand to 8 bytes for each number in the set. A malicious IMAP server may send specially crafted APPENDUID or COPYUID responses with very large uid-set ranges. The Net::IMAP client parses each server response in a separate thread, as soon as each responses is received…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7fc5-f82f-cx69
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25186 Advisory: Possible DoS by memory exhaustion in net-imap IDs: CVE-2025-25186, GHSA-7fc5-f82f-cx69 Record: https://patchnext.com/advisories/cve-2025-25186 (revision 1, source checked 26 Oct 2026, 15:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net-imap 0.5.6, 0.4.19, 0.3.8. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems net-imap: affected >= 0.3.2, < 0.3.8; >= 0.4.0, < 0.4.19; >= 0.5.0, < 0.5.6; fixed in 0.4.19, 0.5.6, 0.3.8 ## Suggested inspection (read-only) - RubyGems net-imap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net-imap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7fc5-f82f-cx69 (GitHub-reviewed advisory GHSA-7fc5-f82f-cx69 lists affected ranges: RubyGems net-imap >=0.3.2 =0.4.0 =0.5.0 <0.5.6) Commands are suggestions: review each one before running it.
Loading voting…