Possible Log Injection in Rack::CommonLogger
CVE-2025-25184GHSA-7g2v-jj9q-g3rg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rack 3.1.10, 3.0.12, 2.2.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rack
- Affected
- < 2.2.11>= 3.0, < 3.0.12>= 3.1, < 3.1.10
- Fixed in
- 2.2.11, 3.1.10, 3.0.12
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7g2v-jj9q-g3rg lists affected ranges: RubyGems rack >=0 =3.0 =3.1 <3.1.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2025-25184: 1.19% estimated exploitation activity in the next 30 days; percentile 67.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Rack::CommonLogger can be exploited by crafting input that includes newline characters to manipulate log entries. The supplied proof-of-concept demonstrates injecting malicious content into logs. Details When a user provides the authorization credentials via Rack::Auth::Basic, if success, the username will be put in env['REMOTEUSER'] and later be used by Rack::CommonLogger for logging purposes. The issue occurs when a server intentionally or unintentionally allows a user creation with the username contain CRLF and white space characters, or the server just want to log every login attempts. If an attacker enters a username with CRLF character, the logger will log the malicious username with CRLF characters into the logfile. Impact Attackers can break log formats or insert fraudulent entries, potentially obscuring real activity or injecting malicious data into log files. Mitigation - Update to the latest version of Rack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7g2v-jj9q-g3rg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-25184 Advisory: Possible Log Injection in Rack::CommonLogger IDs: CVE-2025-25184, GHSA-7g2v-jj9q-g3rg Record: https://patchnext.com/advisories/cve-2025-25184 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rack 3.1.10, 3.0.12, 2.2.11. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rack: affected < 2.2.11; >= 3.0, < 3.0.12; >= 3.1, < 3.1.10; fixed in 2.2.11, 3.1.10, 3.0.12 ## Suggested inspection (read-only) - RubyGems rack: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rack. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7g2v-jj9q-g3rg (GitHub-reviewed advisory GHSA-7g2v-jj9q-g3rg lists affected ranges: RubyGems rack >=0 =3.0 =3.1 <3.1.10) Commands are suggestions: review each one before running it.
Loading voting…