Azure PromptFlow remote code execution related to Jinja templates
CVE-2025-24986GHSA-gprr-v9f2-px3c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (promptflow-tools 1.6.0; promptflow-core 1.17.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI promptflow-tools
- Affected
- < 1.6.0
- Fixed in
- 1.6.0
PyPI promptflow-core
- Affected
- < 1.17.2
- Fixed in
- 1.17.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gprr-v9f2-px3c lists affected ranges: PyPI promptflow-tools >=0 =0 <1.17.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gprr-v9f2-px3c lists affected ranges: PyPI promptflow-tools >=0 =0 <1.17.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-24986: 0.54% estimated exploitation activity in the next 30 days; percentile 45.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper isolation or compartmentalization in Azure PromptFlow allows an unauthorized attacker to execute code over a network.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gprr-v9f2-px3c
- Revision 1 · created ·
Published from osv record GHSA-gprr-v9f2-px3c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24986 Advisory: Azure PromptFlow remote code execution related to Jinja templates IDs: CVE-2025-24986, GHSA-gprr-v9f2-px3c Record: https://patchnext.com/advisories/cve-2025-24986 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: promptflow-tools 1.6.0; promptflow-core 1.17.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI promptflow-tools: affected < 1.6.0; fixed in 1.6.0 - PyPI promptflow-core: affected < 1.17.2; fixed in 1.17.2 ## Suggested inspection (read-only) - `python -m pip show promptflow-tools`: prints the installed version. Run with the environment that serves production active. - `python -m pip show promptflow-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on promptflow-tools, promptflow-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gprr-v9f2-px3c (OSV record GHSA-gprr-v9f2-px3c lists affected ranges: PyPI promptflow-tools >=0 =0 <1.17.2 (fixed)) - Verified: https://github.com/advisories/GHSA-gprr-v9f2-px3c (GitHub-reviewed advisory GHSA-gprr-v9f2-px3c lists affected ranges: PyPI promptflow-tools >=0 =0 <1.17.2) Commands are suggestions: review each one before running it.
Loading voting…