LF Edge eKuiper: Self-XSS in External Service Creation
CVE-2025-24978GHSA-g8rh-fjm6-h2h9
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/lf-edge/ekuiper/v2
- Affected
- < 2.4.0
- Fixed in
- 2.4.0
Go github.com/lf-edge/ekuiper
- Affected
- every version
- Fixed in
- no fixed version recorded
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g8rh-fjm6-h2h9 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GO-2026-6446 lists affected ranges: Go github.com/lf-edge/ekuiper >=0; Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g8rh-fjm6-h2h9 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A Cross-Site Scripting (XSS) vulnerability in external service creation allows an authenticated attacker to inject HTML/script payloads into external service names, which may execute in a user's browser when rendered by administrative web interfaces. Details Prior to v2.4.0, external service registration endpoints did not strictly enforce alphanumeric character restrictions on service names. An operator or attacker with API access could register a service using a crafted name containing HTML elements (such as <iframe src="..."). If an administrative web UI rendered the unescaped service name, arbitrary script execution could occur in the context of the user's browser session. PoC 1. Create an external service JSON definition with a filename containing an XSS payload, e.g. <iframe src="javascript:alert1337".json inside a ZIP archive. 2. In external service creation, upload the ZIP and provide the matching service name: <iframe src="javascript:alert1337". 3. Upon service…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g8rh-fjm6-h2h9
- Revision 2 · amended ·
Amended from osv record GO-2026-6446
- Revision 1 · created ·
Published from osv record GHSA-g8rh-fjm6-h2h9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24978 Advisory: LF Edge eKuiper: Self-XSS in External Service Creation IDs: CVE-2025-24978, GHSA-g8rh-fjm6-h2h9 Record: https://patchnext.com/advisories/cve-2025-24978 (revision 3, source checked 26 Oct 2026, 15:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: github.com/lf-edge/ekuiper/v2 2.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/lf-edge/ekuiper/v2: affected < 2.4.0; fixed in 2.4.0 - Go github.com/lf-edge/ekuiper: affected every version ## Suggested inspection (read-only) - Go github.com/lf-edge/ekuiper/v2: check the installed version with your package manager. - Go github.com/lf-edge/ekuiper: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/lf-edge/ekuiper/v2, github.com/lf-edge/ekuiper. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g8rh-fjm6-h2h9 (OSV record GHSA-g8rh-fjm6-h2h9 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0 (fixed)) - Verified: https://osv.dev/vulnerability/GO-2026-6446 (OSV record GO-2026-6446 lists affected ranges: Go github.com/lf-edge/ekuiper >=0; Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-g8rh-fjm6-h2h9 (GitHub-reviewed advisory GHSA-g8rh-fjm6-h2h9 lists affected ranges: Go github.com/lf-edge/ekuiper/v2 >=0 <2.4.0) Commands are suggestions: review each one before running it.
Loading voting…