SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine
CVE-2025-24970GHSA-4g8c-wm8x-jfhw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.netty:netty-handler 4.1.118.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.netty:netty-handler
- Affected
- >= 4.1.91.Final, <= 4.1.117.Final
- Fixed in
- 4.1.118.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4g8c-wm8x-jfhw lists affected ranges: Maven io.netty:netty-handler >=4.1.91.Final <=4.1.117.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2025-24970: 2.19% estimated exploitation activity in the next 30 days; percentile 82.47 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When a special crafted packet is received via SslHandler it doesn't correctly handle validation of such a packet in all cases which can lead to a native crash. Workarounds As workaround its possible to either disable the usage of the native SSLEngine or changing the code from: to:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4g8c-wm8x-jfhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24970 Advisory: SslHandler doesn't correctly validate packets which can lead to native crash when using native SSLEngine IDs: CVE-2025-24970, GHSA-4g8c-wm8x-jfhw Record: https://patchnext.com/advisories/cve-2025-24970 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.netty:netty-handler 4.1.118.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.netty:netty-handler: affected >= 4.1.91.Final, <= 4.1.117.Final; fixed in 4.1.118.Final ## Suggested inspection (read-only) - Maven io.netty:netty-handler: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.netty:netty-handler. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4g8c-wm8x-jfhw (GitHub-reviewed advisory GHSA-4g8c-wm8x-jfhw lists affected ranges: Maven io.netty:netty-handler >=4.1.91.Final <=4.1.117.Final) Commands are suggestions: review each one before running it.
Loading voting…