Skip to content

← Actionable
Critical, CVSS 9.6amended

Vitest allows Remote Code Execution when accessing a malicious website while Vitest API server is listening

CVE-2025-24964GHSA-9crc-q9x8-hgqq

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vitest

    Affected
    >= 1.0.0, < 1.6.1>= 2.0.0, < 2.1.9>= 3.0.0, < 3.0.5<= 0.0.125
    Fixed in
    1.6.1, 2.1.9, 3.0.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
EPSS
  • CVE-2025-24964: 0.68% estimated exploitation activity in the next 30 days; percentile 52.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Arbitrary remote Code Execution when accessing a malicious website while Vitest API server is listening by Cross-site WebSocket hijacking (CSWSH) attacks. Details When api option is enabled (Vitest UI enables it), Vitest starts a WebSocket server. This WebSocket server did not check Origin header and did not have any authorization mechanism and was vulnerable to CSWSH attacks. https://github.com/vitest-dev/vitest/blob/9a581e1c43e5c02b11e2a8026a55ce6a8cb35114/packages/vitest/src/api/setup.ts#L32-L46 This WebSocket server has saveTestFile API that can edit a test file and rerun API that can rerun the tests. An attacker can execute arbitrary code by injecting a code in a test file by the saveTestFile API and then running that file by calling the rerun API. https://github.com/vitest-dev/vitest/blob/9a581e1c43e5c02b11e2a8026a55ce6a8cb35114/packages/vitest/src/api/setup.ts#L66-L76 PoC 1. Open Vitest UI. 2. Access a malicious web site with the script below. 3. If you have calc…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-9crc-q9x8-hgqq

  2. Revision 1 · created ·

    Published from osv record GHSA-9crc-q9x8-hgqq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24964

Advisory: Vitest allows Remote Code Execution when accessing a malicious website while Vitest API server is listening
IDs: CVE-2025-24964, GHSA-9crc-q9x8-hgqq
Record: https://patchnext.com/advisories/cve-2025-24964 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: vitest 3.0.5, 2.1.9, 1.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vitest: affected >= 1.0.0, < 1.6.1; >= 2.0.0, < 2.1.9; >= 3.0.0, < 3.0.5; <= 0.0.125; fixed in 1.6.1, 2.1.9, 3.0.5

## Suggested inspection (read-only)
- `npm ls vitest --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vitest.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9crc-q9x8-hgqq (OSV record GHSA-9crc-q9x8-hgqq lists affected ranges: npm vitest >=1.0.0 =2.0.0 =3.0.0 =0 <=0.0.125)
- Verified: https://github.com/advisories/GHSA-9crc-q9x8-hgqq (GitHub-reviewed advisory GHSA-9crc-q9x8-hgqq lists affected ranges: npm vitest >=1.0.0 =2.0.0 =3.0.0 =0 <=0.0.125)

Commands are suggestions: review each one before running it.

Loading voting…