Skip to content

← Actionable
Medium, CVSS 5.9amended

Vitest browser mode serves arbitrary files

CVE-2025-24963GHSA-8gvc-j273-4wm5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vitest/browser 3.0.4, 2.1.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm @vitest/browser

    Affected
    >= 2.0.4, < 2.1.9>= 3.0.0, < 3.0.4
    Fixed in
    3.0.4, 2.1.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-24963: 2.40% estimated exploitation activity in the next 30 days; percentile 84.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary screenshot-error handler on the browser mode HTTP server that responds any file on the file system. Especially if the server is exposed on the network by browser.api.host: true, an attacker can send a request to that handler from remote to get the content of arbitrary files. Details This screenshot-error handler on the browser mode HTTP server responds any file on the file system. https://github.com/vitest-dev/vitest/blob/f17918a79969d27a415f70431e08a9445b051e45/packages/browser/src/node/plugin.ts#L88-L130 This code was added by https://github.com/vitest-dev/vitest/commit/2d62051f13b4b0939b2f7e94e88006d830dc4d1f. PoC 1. Create a directory and change the current directory to that directory 1. Run npx vitest init browser 1. Run npm run test:browser 2. Run curl http://localhost:63315/screenshot-error?file=/path/to/any/file Impact Users explicitly exposing the browser mode server to the network by browser.api.host: true may get any files exposed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8gvc-j273-4wm5

  2. Revision 1 · created ·

    Published from osv record GHSA-8gvc-j273-4wm5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24963

Advisory: Vitest browser mode serves arbitrary files
IDs: CVE-2025-24963, GHSA-8gvc-j273-4wm5
Record: https://patchnext.com/advisories/cve-2025-24963 (revision 2, source checked 26 Oct 2026, 12:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @vitest/browser 3.0.4, 2.1.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @vitest/browser: affected >= 2.0.4, < 2.1.9; >= 3.0.0, < 3.0.4; fixed in 3.0.4, 2.1.9

## Suggested inspection (read-only)
- `npm ls @vitest/browser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @vitest/browser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8gvc-j273-4wm5 (OSV record GHSA-8gvc-j273-4wm5 lists affected ranges: npm @vitest/browser >=2.0.4 =3.0.0 <3.0.4 (fixed))
- Verified: https://github.com/advisories/GHSA-8gvc-j273-4wm5 (GitHub-reviewed advisory GHSA-8gvc-j273-4wm5 lists affected ranges: npm @vitest/browser >=2.0.4 =3.0.0 <3.0.4)

Commands are suggestions: review each one before running it.

Loading voting…