Skip to content

← Actionable
Medium, CVSS 6.3

rust-openssl ssl::select_next_proto use after free

CVE-2025-24898GHSA-rpmj-rpgj-qmpm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openssl 0.10.70), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io openssl

    Affected
    >= 0.10.0, < 0.10.70
    Fixed in
    0.10.70

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-24898: 0.68% estimated exploitation activity in the next 30 days; percentile 52.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact ssl::selectnextproto can return a slice pointing into the server argument's buffer but with a lifetime bound to the client argument. In situations where the server buffer's lifetime is shorter than the client buffer's, this can cause a use after free. This could cause the server to crash or to return arbitrary memory contents to the client. Patches openssl 0.10.70 fixes the signature of ssl::selectnextproto to properly constrain the output buffer's lifetime to that of both input buffers. Workarounds In standard usage of ssl::selectnextproto in the callback passed to SslContextBuilder::setalpnselectcallback, code is only affected if the server buffer is constructed within the callback. For example: Not vulnerable - the server buffer has a 'static lifetime: Not vulnerable - the server buffer outlives the handshake: Vulnerable - the server buffer is freed when the callback returns: References https://github.com/sfackler/rust-openssl/pull/2360

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rpmj-rpgj-qmpm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24898

Advisory: rust-openssl ssl::select_next_proto use after free
IDs: CVE-2025-24898, GHSA-rpmj-rpgj-qmpm
Record: https://patchnext.com/advisories/cve-2025-24898 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openssl 0.10.70. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io openssl: affected >= 0.10.0, < 0.10.70; fixed in 0.10.70

## Suggested inspection (read-only)
- crates.io openssl: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openssl.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rpmj-rpgj-qmpm (GitHub-reviewed advisory GHSA-rpmj-rpgj-qmpm lists affected ranges: crates.io openssl >=0.10.0 <0.10.70)

Commands are suggestions: review each one before running it.

Loading voting…