XWiki Platform allows remote code execution as guest via SolrSearchMacros request
CVE-2025-24893GHSA-rr6p-3pfg-562j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-search-solr-ui 16.4.1, 15.10.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-search-solr-ui
- Affected
- >= 5.3-milestone-2, < 15.10.11>= 16.0.0-rc-1, < 16.4.1
- Fixed in
- 15.10.11, 16.4.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rr6p-3pfg-562j lists affected ranges: Maven org.xwiki.platform:xwiki-platform-search-solr-ui >=5.3-milestone-2 =16.0.0-rc-1 <16.4.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-24893 to the Known Exploited Vulnerabilities catalog on 2025-10-30.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2025-10-30).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-24893: 99.97% estimated exploitation activity in the next 30 days; percentile 99.98 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Any guest can perform arbitrary remote code execution through a request to SolrSearch. This impacts the confidentiality, integrity and availability of the whole XWiki installation. To reproduce on an instance, without being logged in, go to <host/xwiki/bin/get/Main/SolrSearch?media=rss&text=%7D%7D%7D%7B%7Basync%20async%3Dfalse%7D%7D%7B%7Bgroovy%7D%7Dprintln%28"Hello%20from"%20%2B%20"%20search%20text%3A"%20%2B%20%2823%20%2B%2019%29%29%7B%7B%2Fgroovy%7D%7D%7B%7B%2Fasync%7D%7D%20. If there is an output, and the title of the RSS feed contains Hello from search text:42, then the instance is vulnerable. Patches This vulnerability has been patched in XWiki 15.10.11, 16.4.1 and 16.5.0RC1. Workarounds This line in Main.SolrSearchMacros can be edited to match the rawResponse macro defined here with a content type of application/xml, instead of simply outputting the content of the feed. References https://jira.xwiki.org/browse/XWIKI-22149…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rr6p-3pfg-562j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24893 Advisory: XWiki Platform allows remote code execution as guest via SolrSearchMacros request IDs: CVE-2025-24893, GHSA-rr6p-3pfg-562j Record: https://patchnext.com/advisories/cve-2025-24893 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-search-solr-ui 16.4.1, 15.10.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-search-solr-ui: affected >= 5.3-milestone-2, < 15.10.11; >= 16.0.0-rc-1, < 16.4.1; fixed in 15.10.11, 16.4.1 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-search-solr-ui: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-search-solr-ui. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rr6p-3pfg-562j (GitHub-reviewed advisory GHSA-rr6p-3pfg-562j lists affected ranges: Maven org.xwiki.platform:xwiki-platform-search-solr-ui >=5.3-milestone-2 =16.0.0-rc-1 <16.4.1) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-24893 to the Known Exploited Vulnerabilities catalog on 2025-10-30.) Commands are suggestions: review each one before running it.
Loading voting…