Authentication bypass in @sap/approuter
CVE-2025-24876GHSA-cpfx-964w-4jvp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@sap/approuter 16.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @sap/approuter
- Affected
- >= 2.6.1, < 16.7.2
- Fixed in
- 16.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cpfx-964w-4jvp lists affected ranges: npm @sap/approuter >=2.6.1 <16.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cpfx-964w-4jvp lists affected ranges: npm @sap/approuter >=2.6.1 <16.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-24876: 0.50% estimated exploitation activity in the next 30 days; percentile 42.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The SAP Approuter Node.js package version v16.7.1 and before is vulnerable to Authentication bypass. When trading an authorization code, an attacker can steal the session of the victim by injecting malicious payload, causing High impact on confidentiality and integrity of the application.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-cpfx-964w-4jvp
- Revision 1 · created ·
Published from osv record GHSA-cpfx-964w-4jvp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24876 Advisory: Authentication bypass in @sap/approuter IDs: CVE-2025-24876, GHSA-cpfx-964w-4jvp Record: https://patchnext.com/advisories/cve-2025-24876 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @sap/approuter 16.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @sap/approuter: affected >= 2.6.1, < 16.7.2; fixed in 16.7.2 ## Suggested inspection (read-only) - `npm ls @sap/approuter --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @sap/approuter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cpfx-964w-4jvp (OSV record GHSA-cpfx-964w-4jvp lists affected ranges: npm @sap/approuter >=2.6.1 <16.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-cpfx-964w-4jvp (GitHub-reviewed advisory GHSA-cpfx-964w-4jvp lists affected ranges: npm @sap/approuter >=2.6.1 <16.7.2) Commands are suggestions: review each one before running it.
Loading voting…