Mattermost Fails to Enforce Proper Access Controls on /api/v4/audits Endpoint
CVE-2025-24866GHSA-xfq9-hh5x-xfq9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 9.11.9, 8.0.0-20250204211032-f52e08754c49), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 9.11.0, < 9.11.9< 8.0.0-20250204211032-f52e08754c49
- Fixed in
- 9.11.9, 8.0.0-20250204211032-f52e08754c49
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xfq9-hh5x-xfq9 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.11.0 =0 <8.0.0-20250204211032-f52e08754c49
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 2.7 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-24866: 0.30% estimated exploitation activity in the next 30 days; percentile 22.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 9.11.x <= 9.11.8 fail to enforce proper access controls on the /api/v4/audits endpoint, allowing users with delegated granular administration roles who lack access to Compliance Monitoring to retrieve User Activity Logs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xfq9-hh5x-xfq9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24866 Advisory: Mattermost Fails to Enforce Proper Access Controls on `/api/v4/audits` Endpoint IDs: CVE-2025-24866, GHSA-xfq9-hh5x-xfq9 Record: https://patchnext.com/advisories/cve-2025-24866 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 9.11.9, 8.0.0-20250204211032-f52e08754c49. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 9.11.0, < 9.11.9; < 8.0.0-20250204211032-f52e08754c49; fixed in 9.11.9, 8.0.0-20250204211032-f52e08754c49 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xfq9-hh5x-xfq9 (GitHub-reviewed advisory GHSA-xfq9-hh5x-xfq9 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=9.11.0 =0 <8.0.0-20250204211032-f52e08754c49) Commands are suggestions: review each one before running it.
Loading voting…