Skip to content

← Actionable
Medium, CVSS 5.4

Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions

CVE-2025-24860GHSA-3cjf-fwcq-xh22

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.cassandra:cassandra-all 5.0.3, 4.1.8, 4.0.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-24860: 1.09% estimated exploitation activity in the next 30 days; percentile 65.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incorrect Authorization vulnerability in Apache Cassandra allowing users to access a datacenter or IP/CIDR groups they should not be able to when using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer. Users with restricted data center access can update their own permissions via data control language (DCL) statements on affected versions. This issue affects Apache Cassandra: from 4.0.0 through 4.0.15 and from 4.1.0 through 4.1.7 for CassandraNetworkAuthorizer, and from 5.0.0 through 5.0.2 for both CassandraNetworkAuthorizer and CassandraCIDRAuthorizer. Operators using CassandraNetworkAuthorizer or CassandraCIDRAuthorizer on affected versions should review data access rules for potential breaches. Users are recommended to upgrade to versions 4.0.16, 4.1.8, 5.0.3, which fixes the issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3cjf-fwcq-xh22

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24860

Advisory: Apache Cassandra: CassandraNetworkAuthorizer and CassandraCIDRAuthorizer can be bypassed allowing access to different network regions
IDs: CVE-2025-24860, GHSA-3cjf-fwcq-xh22
Record: https://patchnext.com/advisories/cve-2025-24860 (revision 1, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.cassandra:cassandra-all 5.0.3, 4.1.8, 4.0.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.cassandra:cassandra-all: affected >= 4.0-alpha1, < 4.0.16; >= 4.1-alpha1, < 4.1.8; >= 5.0-alpha1, < 5.0.3; fixed in 4.1.8, 5.0.3, 4.0.16

## Suggested inspection (read-only)
- Maven org.apache.cassandra:cassandra-all: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.cassandra:cassandra-all.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3cjf-fwcq-xh22 (GitHub-reviewed advisory GHSA-3cjf-fwcq-xh22 lists affected ranges: Maven org.apache.cassandra:cassandra-all >=4.0-alpha1 =4.1-alpha1 =5.0-alpha1 <5.0.3)

Commands are suggestions: review each one before running it.

Loading voting…