Mattermost Incorrect Authorization vulnerability
CVE-2025-24839GHSA-j639-m367-75cf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.5.2, 10.4.4, 9.11.10, 8.0.0-20250314142426-c049748b8863), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 10.5.0, < 10.5.2>= 10.4.0, < 10.4.4>= 9.11.0, < 9.11.10< 8.0.0-20250314142426-c049748b8863
- Fixed in
- 8.0.0-20250314142426-c049748b8863, 10.4.4, 10.5.2, 9.11.10
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j639-m367-75cf lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =10.4.0 =9.11.0 =0 <8.0.0-20250314142426-c049748b8863
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2025-24839: 0.23% estimated exploitation activity in the next 30 days; percentile 13.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to prevent Wrangler posts from triggering AI responses. This vulnerability allows users without access to the AI bot to activate it by attaching the activateai override property to a post via the Wrangler plugin, provided both the AI and Wrangler plugins are enabled.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j639-m367-75cf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24839 Advisory: Mattermost Incorrect Authorization vulnerability IDs: CVE-2025-24839, GHSA-j639-m367-75cf Record: https://patchnext.com/advisories/cve-2025-24839 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.5.2, 10.4.4, 9.11.10, 8.0.0-20250314142426-c049748b8863. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 10.5.0, < 10.5.2; >= 10.4.0, < 10.4.4; >= 9.11.0, < 9.11.10; < 8.0.0-20250314142426-c049748b8863; fixed in 8.0.0-20250314142426-c049748b8863, 10.4.4, 10.5.2, 9.11.10 ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j639-m367-75cf (GitHub-reviewed advisory GHSA-j639-m367-75cf lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =10.4.0 =9.11.0 =0 <8.0.0-20250314142426-c049748b8863) Commands are suggestions: review each one before running it.
Loading voting…