Apache Solr vulnerable to Execution with Unnecessary Privileges
CVE-2025-24814GHSA-68r2-fwcg-qpm8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.solr:solr-core 9.8.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.solr:solr-core
- Affected
- < 9.8.0
- Fixed in
- 9.8.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-68r2-fwcg-qpm8 lists affected ranges: Maven org.apache.solr:solr-core >=0 <9.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-24814: 1.22% estimated exploitation activity in the next 30 days; percentile 68.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Core creation allows users to replace "trusted" configset files with arbitrary configuration Solr instances that (1) use the "FileSystemConfigSetService" component (the default in "standalone" or "user-managed" mode), and (2) are running without authentication and authorization are vulnerable to a sort of privilege escalation wherein individual "trusted" configset files can be ignored in favor of potentially-untrusted replacements available elsewhere on the filesystem. These replacement config files are treated as "trusted" and can use "<lib" tags to add to Solr's classpath, which an attacker might use to load malicious code as a searchComponent or other plugin. This issue affects all Apache Solr versions up through Solr 9.7. Users can protect against the vulnerability by enabling authentication and authorization on their Solr clusters or switching to SolrCloud (and away from "FileSystemConfigSetService"). Users are also recommended to upgrade to Solr 9.8.0, which mitigates this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-68r2-fwcg-qpm8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24814 Advisory: Apache Solr vulnerable to Execution with Unnecessary Privileges IDs: CVE-2025-24814, GHSA-68r2-fwcg-qpm8 Record: https://patchnext.com/advisories/cve-2025-24814 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.solr:solr-core 9.8.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.solr:solr-core: affected < 9.8.0; fixed in 9.8.0 ## Suggested inspection (read-only) - Maven org.apache.solr:solr-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.solr:solr-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-68r2-fwcg-qpm8 (GitHub-reviewed advisory GHSA-68r2-fwcg-qpm8 lists affected ranges: Maven org.apache.solr:solr-core >=0 <9.8.0) Commands are suggestions: review each one before running it.
Loading voting…