Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT
CVE-2025-24813GHSA-83qj-6fr2-vhqg
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat-catalina
- Affected
- >= 11.0.0-M1, < 11.0.3>= 10.1.0-M1, < 10.1.35>= 9.0.0.M1, < 9.0.99>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.3, 9.0.99, 10.1.35
Maven org.apache.tomcat.embed:tomcat-embed-core
- Affected
- >= 11.0.0-M1, < 11.0.3>= 10.1.0-M1, < 10.1.35>= 9.0.0.M1, < 9.0.99>= 8.5.0, <= 8.5.100
- Fixed in
- 11.0.3, 9.0.99, 10.1.35
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-83qj-6fr2-vhqg lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-24813 to the Known Exploited Vulnerabilities catalog on 2025-04-01.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2025-04-01).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS 4.0
- 9.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:A · score source
- EPSS
- CVE-2025-24813: 99.94% estimated exploitation activity in the next 30 days; percentile 99.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files: - writes enabled for the default servlet (disabled by default) - support for partial PUT (enabled by default) - a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads - attacker knowledge of the names of security sensitive files being uploaded - the security sensitive files also being uploaded via partial PUT If…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-83qj-6fr2-vhqg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24813 Advisory: Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT IDs: CVE-2025-24813, GHSA-83qj-6fr2-vhqg Record: https://patchnext.com/advisories/cve-2025-24813 (revision 1, source checked 26 Oct 2026, 16:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.2) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Partial vendor fix; fixed versions by package: org.apache.tomcat:tomcat-catalina 11.0.3, 10.1.35, 9.0.99; org.apache.tomcat.embed:tomcat-embed-core 11.0.3, 10.1.35, 9.0.99. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat-catalina: affected >= 11.0.0-M1, < 11.0.3; >= 10.1.0-M1, < 10.1.35; >= 9.0.0.M1, < 9.0.99; >= 8.5.0, <= 8.5.100; fixed in 11.0.3, 9.0.99, 10.1.35 - Maven org.apache.tomcat.embed:tomcat-embed-core: affected >= 11.0.0-M1, < 11.0.3; >= 10.1.0-M1, < 10.1.35; >= 9.0.0.M1, < 9.0.99; >= 8.5.0, <= 8.5.100; fixed in 11.0.3, 9.0.99, 10.1.35 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat-catalina: check the installed version with your package manager. - Maven org.apache.tomcat.embed:tomcat-embed-core: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat-catalina, org.apache.tomcat.embed:tomcat-embed-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-83qj-6fr2-vhqg (GitHub-reviewed advisory GHSA-83qj-6fr2-vhqg lists affected ranges: Maven org.apache.tomcat:tomcat-catalina >=11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 =11.0.0-M1 =10.1.0-M1 =9.0.0.M1 =8.5.0 <=8.5.100) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-24813 to the Known Exploited Vulnerabilities catalog on 2025-04-01.) Commands are suggestions: review each one before running it.
Loading voting…