MobSF Local Privilege Escalation
CVE-2025-24805GHSA-79f6-p65j-3m2m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mobsf 4.3.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI mobsf
- Affected
- <= 4.3.0
- Fixed in
- 4.3.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-79f6-p65j-3m2m lists affected ranges: PyPI mobsf >=0 <4.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-79f6-p65j-3m2m lists affected ranges: PyPI mobsf >=0 <=4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N · score source
- EPSS
- CVE-2025-24805: 0.36% estimated exploitation activity in the next 30 days; percentile 30.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Product: Mobile Security Framework (MobSF) Version: 4.3.0 CWE-ID: CWE-269: Improper Privilege Management CVSS vector v.4.0: 7.1 (AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:N/SA:N) CVSS vector v.3.1: 6.5 (AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N) Description: MobSF has a functionality of dividing users by roles. This functionality is not efficient, because any registered user can get API Token with all privileges. Impact: Information Disclosure Vulnerable component: Code output component (/sourcecode) Exploitation conditions: authorized user Mitigation: Remove token output in the returned js-script Researcher: Egor Filatov (Positive Technologies) Research Researcher discovered zero-day vulnerability «Local Privilege Escalation» in Mobile Security Framework (MobSF). To reproduce the vulnerability follow the steps below. • A user with minimal privileges is required, so the administrator must create a user account <img width="215" alt="fig1"…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-79f6-p65j-3m2m
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-79f6-p65j-3m2m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24805 Advisory: MobSF Local Privilege Escalation IDs: CVE-2025-24805, GHSA-79f6-p65j-3m2m Record: https://patchnext.com/advisories/cve-2025-24805 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mobsf 4.3.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI mobsf: affected <= 4.3.0; fixed in 4.3.1 ## Suggested inspection (read-only) - `python -m pip show mobsf`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mobsf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-79f6-p65j-3m2m (OSV record GHSA-79f6-p65j-3m2m lists affected ranges: PyPI mobsf >=0 <4.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-79f6-p65j-3m2m (GitHub-reviewed advisory GHSA-79f6-p65j-3m2m lists affected ranges: PyPI mobsf >=0 <=4.3.0) Commands are suggestions: review each one before running it.
Loading voting…