Skip to content

← Actionable
High, CVSS 8.6

Soundness issue with Plonky2 look up tables

CVE-2025-24802GHSA-hj49-h7fq-px5h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (plonky2 1.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io plonky2

    Affected
    >= 1.0.0, <= 1.0.0
    Fixed in
    1.0.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:H/A:N
EPSS
  • CVE-2025-24802: 0.32% estimated exploitation activity in the next 30 days; percentile 25.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Lookup tables, whose length is not divisible by 26 = floor(numroutedwires / 3) always include the 0 - 0 input-output pair. Thus a malicious prover can always prove that f(0) = 0 for any lookup table f (unless its length happens to be divisible by 26). The cause of problem is that the LookupTableGate-s are padded with zeros. The fix is done by padding with an existing table pair, similarly to LookupGate. A workaround from the user side is to extend the table (by repeating some entries) so that its length becomes divisible by 26. Fortunately, the seemingly most common use case, namely, hash functions with table-based sbox-es, are not vulnerable: both Monolith's and Tip5/Tip4's s-box tables already map 0 to 0; more generally, forcing several (0,0) pairs inside such a hash function appears to be a too strong restriction to find an otherwise valid trace. A malicious prover exploiting this could cheat a circuit which statement is the following: - output x + f(x) for some private…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hj49-h7fq-px5h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24802

Advisory: Soundness issue with Plonky2 look up tables
IDs: CVE-2025-24802, GHSA-hj49-h7fq-px5h
Record: https://patchnext.com/advisories/cve-2025-24802 (revision 1, source checked 26 Oct 2026, 15:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: plonky2 1.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io plonky2: affected >= 1.0.0, <= 1.0.0; fixed in 1.0.1

## Suggested inspection (read-only)
- crates.io plonky2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on plonky2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hj49-h7fq-px5h (GitHub-reviewed advisory GHSA-hj49-h7fq-px5h lists affected ranges: crates.io plonky2 >=1.0.0 <=1.0.0)

Commands are suggestions: review each one before running it.

Loading voting…