ismp-grandpa crate accepted incorrect signatures
CVE-2025-24800GHSA-wwx5-gpgr-vxr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (grandpa-verifier-primitives 0.1.2; grandpa-verifier 0.1.2; ismp-grandpa 15.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io grandpa-verifier-primitives
- Affected
- < 0.1.2
- Fixed in
- 0.1.2
crates.io grandpa-verifier
- Affected
- < 0.1.2
- Fixed in
- 0.1.2
crates.io ismp-grandpa
- Affected
- < 15.0.1
- Fixed in
- 15.0.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wwx5-gpgr-vxr7 lists affected ranges: crates.io ismp-grandpa >=0 =0 =0 <0.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2025-24800: 0.32% estimated exploitation activity in the next 30 days; percentile 24.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A critical vulnerability was discovered in the ismp-grandpa crate, that allowed a malicious prover easily convince the verifier of the finality of arbitrary headers. Description The vulnerability manifests as a verifer that only accepts incorrect signatures of Grandpa precommits and was introduced in this specific commit. Perhaps due to unfamiliarity with core substrate APIs. The if statement should have included a negation check, similar to the previous code, but this was omitted. Causing the verifier to only accept invalid signatures. This vulnerability remained undetected even with integration tests, as the prover was also misconfigured to initialize the Grandpa verifier with the incorrect authority setid. This causes verification of honest precommit signatures to fail as the message is now malformed, but the verifier indeed only accepts signatures or messages that fail the verification check. But even more devastatingly, the verifier will also accept malicious GRANDPA signatures…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wwx5-gpgr-vxr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24800 Advisory: ismp-grandpa crate accepted incorrect signatures IDs: CVE-2025-24800, GHSA-wwx5-gpgr-vxr7 Record: https://patchnext.com/advisories/cve-2025-24800 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: grandpa-verifier-primitives 0.1.2; grandpa-verifier 0.1.2; ismp-grandpa 15.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io grandpa-verifier-primitives: affected < 0.1.2; fixed in 0.1.2 - crates.io grandpa-verifier: affected < 0.1.2; fixed in 0.1.2 - crates.io ismp-grandpa: affected < 15.0.1; fixed in 15.0.1 ## Suggested inspection (read-only) - crates.io grandpa-verifier-primitives: check the installed version with your package manager. - crates.io grandpa-verifier: check the installed version with your package manager. - crates.io ismp-grandpa: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on grandpa-verifier-primitives, grandpa-verifier, ismp-grandpa. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wwx5-gpgr-vxr7 (GitHub-reviewed advisory GHSA-wwx5-gpgr-vxr7 lists affected ranges: crates.io ismp-grandpa >=0 =0 =0 <0.1.2) Commands are suggestions: review each one before running it.
Loading voting…