Skip to content

← Actionable
Medium, CVSS 4.4amended

snowflake-connector-python vulnerable to insecure cache files permissions

CVE-2025-24795GHSA-r2x6-cjg7-8r43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-connector-python 3.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2025-24795: 0.14% estimated exploitation activity in the next 30 days; percentile 3.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. On Linux systems, when temporary credential caching is enabled, the Snowflake Connector for Python will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 2.3.7 through 3.13.0. Snowflake fixed the issue in version 3.13.1. Vulnerability Details On Linux, when either EXTERNALBROWSER or USERNAMEPASSWORDMFA authentication methods are used with temporary credential caching enabled, the Snowflake Connector for Python will cache the temporary credentials in a local file. In the vulnerable versions of the Driver, this file is created with world-readable permissions. Solution Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r2x6-cjg7-8r43

  2. Revision 1 · created ·

    Published from osv record GHSA-r2x6-cjg7-8r43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24795

Advisory: snowflake-connector-python vulnerable to insecure cache files permissions
IDs: CVE-2025-24795, GHSA-r2x6-cjg7-8r43
Record: https://patchnext.com/advisories/cve-2025-24795 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snowflake-connector-python 3.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI snowflake-connector-python: affected >= 2.3.7, <= 3.13.0; fixed in 3.13.1

## Suggested inspection (read-only)
- `python -m pip show snowflake-connector-python`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snowflake-connector-python.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r2x6-cjg7-8r43 (OSV record GHSA-r2x6-cjg7-8r43 lists affected ranges: PyPI snowflake-connector-python >=2.3.7 <3.13.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r2x6-cjg7-8r43 (GitHub-reviewed advisory GHSA-r2x6-cjg7-8r43 lists affected ranges: PyPI snowflake-connector-python >=2.3.7 <=3.13.0)

Commands are suggestions: review each one before running it.

Loading voting…