Skip to content

← Actionable
High, CVSS 7.0amended

snowflake-connector-python vulnerable to SQL Injection in write_pandas

CVE-2025-24793GHSA-2vpq-fh52-j3wv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (snowflake-connector-python 3.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-24793: 0.31% estimated exploitation activity in the next 30 days; percentile 23.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. A function from the snowflake.connector.pandastools module is vulnerable to SQL injection. This vulnerability affects versions 2.2.5 through 3.13.0. Snowflake fixed the issue in version 3.13.1. Vulnerability Details A function from the snowflake.connector.pandastools module is not sanitizing all of its arguments, and queries using them are not parametrized. An attacker controlling these arguments could achieve SQL injection by passing crafted input. Any SQL executed that way by an attacker would still run in the context of the current session. Solution Snowflake released version 3.13.1 of the Snowflake Connector for Python, which fixes this issue. We recommend users upgrade to version 3.13.1. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our Vulnerability Disclosure…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-2vpq-fh52-j3wv

  2. Revision 1 · created ·

    Published from osv record GHSA-2vpq-fh52-j3wv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24793

Advisory: snowflake-connector-python vulnerable to SQL Injection in write_pandas
IDs: CVE-2025-24793, GHSA-2vpq-fh52-j3wv
Record: https://patchnext.com/advisories/cve-2025-24793 (revision 2, source checked 26 Oct 2026, 13:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: snowflake-connector-python 3.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI snowflake-connector-python: affected >= 2.2.5, <= 3.13.0; fixed in 3.13.1

## Suggested inspection (read-only)
- `python -m pip show snowflake-connector-python`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on snowflake-connector-python.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-2vpq-fh52-j3wv (OSV record GHSA-2vpq-fh52-j3wv lists affected ranges: PyPI snowflake-connector-python >=2.2.5 <3.13.1 (fixed))
- Verified: https://github.com/advisories/GHSA-2vpq-fh52-j3wv (GitHub-reviewed advisory GHSA-2vpq-fh52-j3wv lists affected ranges: PyPI snowflake-connector-python >=2.2.5 <=3.13.0)

Commands are suggestions: review each one before running it.

Loading voting…