Snowflake JDBC uses insecure temporary credential cache file permissions
CVE-2025-24790GHSA-33g6-495w-v8j2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.snowflake:snowflake-jdbc 3.22.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven net.snowflake:snowflake-jdbc
- Affected
- >= 3.6.8, <= 3.21.0
- Fixed in
- 3.22.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-33g6-495w-v8j2 lists affected ranges: Maven net.snowflake:snowflake-jdbc >=3.6.8 <=3.21.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.4 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-24790: 0.19% estimated exploitation activity in the next 30 days; percentile 8.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Issue Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0. Vulnerability Details On Linux, when either EXTERNALBROWSER or USERNAMEPASSWORDMFA authentication methods are used with temporary credential caching enabled, the Snowflake JDBC Driver will cache temporary credentials in a local file. In the vulnerable versions of the Driver, this file is created with world-readable permissions. Solution Snowflake released version 3.22.0 of the Snowflake JDBC Driver, which fixes this issue. We recommend users upgrade to version 3.22.0. Additional Information If you discover a security vulnerability in one of our products or websites, please report the issue to HackerOne. For more information, please see our…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-33g6-495w-v8j2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24790 Advisory: Snowflake JDBC uses insecure temporary credential cache file permissions IDs: CVE-2025-24790, GHSA-33g6-495w-v8j2 Record: https://patchnext.com/advisories/cve-2025-24790 (revision 1, source checked 26 Oct 2026, 16:34 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: net.snowflake:snowflake-jdbc 3.22.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven net.snowflake:snowflake-jdbc: affected >= 3.6.8, <= 3.21.0; fixed in 3.22.0 ## Suggested inspection (read-only) - Maven net.snowflake:snowflake-jdbc: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on net.snowflake:snowflake-jdbc. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-33g6-495w-v8j2 (GitHub-reviewed advisory GHSA-33g6-495w-v8j2 lists affected ranges: Maven net.snowflake:snowflake-jdbc >=3.6.8 <=3.21.0) Commands are suggestions: review each one before running it.
Loading voting…