Skip to content

← Actionable
High, CVSS 7.8

Snowflake JDBC allows an untrusted search path on Windows

CVE-2025-24789GHSA-7hpq-3g6w-pvhf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (net.snowflake:snowflake-jdbc 3.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-24789: 0.26% estimated exploitation activity in the next 30 days; percentile 17.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Issue Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. When the EXTERNALBROWSER authentication method is used on Windows, an attacker with write access to a directory in the %PATH% can escalate their privileges to the user that runs the vulnerable JDBC Driver version. This vulnerability affects versions 3.2.3 through 3.21.0 on Windows. Snowflake fixed the issue in version 3.22.0. Vulnerability Details When the EXTERNALBROWSER authentication method is selected, the Snowflake JDBC Driver on non-macOS operating systems tries to open the SSO URL using xdg-open. Because xdg-open is a Linux program that doesn’t exist in a default Windows installation, a sufficiently privileged attacker could place a malicious executable in one of the directories on the %PATH% and achieve local privilege escalation to the user running the JDBC Driver. Solution Snowflake released version 3.22.0 of the Snowflake JDBC Driver, which fixes this issue. We recommend users upgrade…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7hpq-3g6w-pvhf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24789

Advisory: Snowflake JDBC allows an untrusted search path on Windows
IDs: CVE-2025-24789, GHSA-7hpq-3g6w-pvhf
Record: https://patchnext.com/advisories/cve-2025-24789 (revision 1, source checked 26 Oct 2026, 16:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: net.snowflake:snowflake-jdbc 3.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven net.snowflake:snowflake-jdbc: affected >= 3.2.3, <= 3.21.0; fixed in 3.22.0

## Suggested inspection (read-only)
- Maven net.snowflake:snowflake-jdbc: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on net.snowflake:snowflake-jdbc.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7hpq-3g6w-pvhf (GitHub-reviewed advisory GHSA-7hpq-3g6w-pvhf lists affected ranges: Maven net.snowflake:snowflake-jdbc >=3.2.3 <=3.21.0)

Commands are suggestions: review each one before running it.

Loading voting…