Mattermost vulnerable to Incorrect Implementation of Authentication Algorithm
CVE-2025-2475GHSA-6rqh-8465-2xcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.5.2, 9.11.10, 8.0.0-20250220161544-fd356b62b4dd), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/mattermost/mattermost/server/v8
- Affected
- >= 10.5.0, < 10.5.2>= 9.11.0, < 9.11.10< 8.0.0-20250220161544-fd356b62b4dd
- Fixed in
- 10.5.2, 9.11.10, 8.0.0-20250220161544-fd356b62b4dd
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6rqh-8465-2xcw lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =9.11.0 =0 <8.0.0-20250220161544-fd356b62b4dd
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2025-2475: 0.23% estimated exploitation activity in the next 30 days; percentile 14.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to invalidate the cache when a user account is converted to a bot which allows an attacker to login to the bot exactly one time via normal credentials.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6rqh-8465-2xcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-2475 Advisory: Mattermost vulnerable to Incorrect Implementation of Authentication Algorithm IDs: CVE-2025-2475, GHSA-6rqh-8465-2xcw Record: https://patchnext.com/advisories/cve-2025-2475 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.5.2, 9.11.10, 8.0.0-20250220161544-fd356b62b4dd. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/mattermost/mattermost/server/v8: affected >= 10.5.0, < 10.5.2; >= 9.11.0, < 9.11.10; < 8.0.0-20250220161544-fd356b62b4dd; fixed in 10.5.2, 9.11.10, 8.0.0-20250220161544-fd356b62b4dd ## Suggested inspection (read-only) - Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/mattermost/mattermost/server/v8. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6rqh-8465-2xcw (GitHub-reviewed advisory GHSA-6rqh-8465-2xcw lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=10.5.0 =9.11.0 =0 <8.0.0-20250220161544-fd356b62b4dd) Commands are suggestions: review each one before running it.
Loading voting…