Skip to content

← Actionable
Medium, CVSS 4.3

Mattermost fails to restrict channel export of archived channels

CVE-2025-24526GHSA-q8p2-2hwc-jw64

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/mattermost/mattermost/server/v8 10.4.2, 10.3.3, 10.2.3, 9.11.8, 8.0.0-20250110161910-96195f1bd746), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/mattermost/mattermost/server/v8

    Affected
    < 8.0.0-20250110161910-96195f1bd746>= 9.11.0-rc1, < 9.11.8>= 10.2.0-rc1, < 10.2.3>= 10.3.0-rc1, < 10.3.3>= 10.4.0-rc1, < 10.4.2
    Fixed in
    9.11.8, 10.3.3, 10.4.2, 10.2.3, 8.0.0-20250110161910-96195f1bd746

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q8p2-2hwc-jw64 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =9.11.0-rc1 =10.2.0-rc1 =10.3.0-rc1 =10.4.0-rc1 <10.4.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2025-24526: 0.29% estimated exploitation activity in the next 30 days; percentile 22.07 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Mattermost versions 10.1.x <= 10.1.3, 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to restrict channel export of archived channels when the "Allow users to view archived channels" is disabled which allows a user to export channel contents when they shouldn't have access to it

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q8p2-2hwc-jw64

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24526

Advisory: Mattermost fails to restrict channel export of archived channels
IDs: CVE-2025-24526, GHSA-q8p2-2hwc-jw64
Record: https://patchnext.com/advisories/cve-2025-24526 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/mattermost/mattermost/server/v8 10.4.2, 10.3.3, 10.2.3, 9.11.8, 8.0.0-20250110161910-96195f1bd746. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/mattermost/mattermost/server/v8: affected < 8.0.0-20250110161910-96195f1bd746; >= 9.11.0-rc1, < 9.11.8; >= 10.2.0-rc1, < 10.2.3; >= 10.3.0-rc1, < 10.3.3; >= 10.4.0-rc1, < 10.4.2; fixed in 9.11.8, 10.3.3, 10.4.2, 10.2.3, 8.0.0-20250110161910-96195f1bd746

## Suggested inspection (read-only)
- Go github.com/mattermost/mattermost/server/v8: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/mattermost/mattermost/server/v8.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q8p2-2hwc-jw64 (GitHub-reviewed advisory GHSA-q8p2-2hwc-jw64 lists affected ranges: Go github.com/mattermost/mattermost/server/v8 >=0 =9.11.0-rc1 =10.2.0-rc1 =10.3.0-rc1 =10.4.0-rc1 <10.4.2)

Commands are suggestions: review each one before running it.

Loading voting…