CKAN has an XSS vector in user uploaded images in group/org and user profiles
CVE-2025-24372GHSA-7pq5-qcp6-mcww
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ckan 2.11.2, 2.10.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI ckan
- Affected
- < 2.10.7>= 2.11.0, < 2.11.2
- Fixed in
- 2.11.2, 2.10.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7pq5-qcp6-mcww lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7pq5-qcp6-mcww lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2025-24372: 0.46% estimated exploitation activity in the next 30 days; percentile 40.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Using a specially crafted file, a user could potentially upload a file containing code that when executed could send arbitrary requests to the server. If that file was opened by an administrator, it could lead to escalation of privileges of the original submitter or other malicious actions. Users must have been registered to the site to exploit this vulnerability. Patches This vulnerability has been fixed in CKAN 2.10.7 and 2.11.2 Workarounds On versions prior to CKAN 2.10.7 and 2.11.2, site maintainers can restrict the file types supported for uploading using the ckan.upload.user.mimetypes / ckan.upload.user.types and ckan.upload.group.mimetypes / ckan.upload.group.types config options. To entirely disable file uploads you can use:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7pq5-qcp6-mcww
- Revision 1 · created ·
Published from osv record GHSA-7pq5-qcp6-mcww
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24372 Advisory: CKAN has an XSS vector in user uploaded images in group/org and user profiles IDs: CVE-2025-24372, GHSA-7pq5-qcp6-mcww Record: https://patchnext.com/advisories/cve-2025-24372 (revision 2, source checked 26 Oct 2026, 13:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ckan 2.11.2, 2.10.7. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI ckan: affected < 2.10.7; >= 2.11.0, < 2.11.2; fixed in 2.11.2, 2.10.7 ## Suggested inspection (read-only) - `python -m pip show ckan`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ckan. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7pq5-qcp6-mcww (OSV record GHSA-7pq5-qcp6-mcww lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7pq5-qcp6-mcww (GitHub-reviewed advisory GHSA-7pq5-qcp6-mcww lists affected ranges: PyPI ckan >=0 =2.11.0 <2.11.2) Commands are suggestions: review each one before running it.
Loading voting…