Skip to content

← Actionable
Medium, CVSS 6.9

CometBFT allows a malicious peer to make node stuck in blocksync

CVE-2025-24371GHSA-22qq-3xwm-r5x4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cometbft/cometbft 1.0.1, 0.38.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2025-24371: 0.46% estimated exploitation activity in the next 30 days; percentile 40.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Name: ASA-2025-001: Malicious peer can disrupt node's ability to sync via blocksync Component: CometBFT [OUTDATED] Criticality: Medium (Considerable Impact; Possible Likelihood per ACMv1.2) Update of Criticality on 2026-03-06: We've made a mistake and over-rated the criticality of this bug in our initial triage. We have calibrated our vulnerability rating internally and updated the criticality of this bug to be Informational (Negligible Impact, Possible Likelihood) Affected versions: <= v0.38.16, v1.0.0 Affected users: Validators, Full nodes Impact A malicious peer may be able to interfere with a node's ability to sync blocks with peers via the blocksync mechanism. In the blocksync protocol peers send their base and latest heights when they connect to a new node (A), which is syncing to the tip of a network. base acts as a lower ground and informs A that the peer only has blocks starting from height base. latest height informs A about the latest block in a network. Normally, nodes…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-22qq-3xwm-r5x4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24371

Advisory: CometBFT allows a malicious peer to make node stuck in blocksync
IDs: CVE-2025-24371, GHSA-22qq-3xwm-r5x4
Record: https://patchnext.com/advisories/cve-2025-24371 (revision 1, source checked 26 Oct 2026, 15:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cometbft/cometbft 1.0.1, 0.38.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cometbft/cometbft: affected >= 1.0.0-alpha.1, < 1.0.1; < 0.38.17; fixed in 0.38.17, 1.0.1

## Suggested inspection (read-only)
- Go github.com/cometbft/cometbft: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cometbft/cometbft.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-22qq-3xwm-r5x4 (GitHub-reviewed advisory GHSA-22qq-3xwm-r5x4 lists affected ranges: Go github.com/cometbft/cometbft >=1.0.0-alpha.1 =0 <0.38.17)

Commands are suggestions: review each one before running it.

Loading voting…