Skip to content

← Actionable
High, CVSS 8.4amended

ASTEVAL Allows Maliciously Crafted Format Strings to Lead to Sandbox Escape

CVE-2025-24359GHSA-3wwr-3g9f-9gc7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (asteval 1.0.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI asteval

    Affected
    <= 1.0.5
    Fixed in
    1.0.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-24359: 0.28% estimated exploitation activity in the next 30 days; percentile 20.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary If an attacker can control the input to the asteval library, they can bypass asteval's restrictions and execute arbitrary Python code in the context of the application using the library. Details The vulnerability is rooted in how asteval performs handling of FormattedValue AST nodes. In particular, the onformattedvalue value uses the dangerous format method of the str class, as shown in the vulnerable code snippet below: The code above allows an attacker to manipulate the value of the string used in the dangerous call fmt.format(fstring=val). This vulnerability can be exploited to access protected attributes by intentionally triggering an AttributeError exception. The attacker can then catch the exception and use its obj attribute to gain arbitrary access to sensitive or protected object properties. PoC The following proof-of-concept (PoC) demonstrates how this vulnerability can be exploited to execute the whoami command on the host machine:

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3wwr-3g9f-9gc7

  2. Revision 1 · created ·

    Published from osv record GHSA-3wwr-3g9f-9gc7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24359

Advisory: ASTEVAL Allows Maliciously Crafted Format Strings to Lead to Sandbox Escape
IDs: CVE-2025-24359, GHSA-3wwr-3g9f-9gc7
Record: https://patchnext.com/advisories/cve-2025-24359 (revision 2, source checked 26 Oct 2026, 13:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: asteval 1.0.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI asteval: affected <= 1.0.5; fixed in 1.0.6

## Suggested inspection (read-only)
- `python -m pip show asteval`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on asteval.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3wwr-3g9f-9gc7 (OSV record GHSA-3wwr-3g9f-9gc7 lists affected ranges: PyPI asteval >=0 <1.0.6 (fixed))
- Verified: https://github.com/advisories/GHSA-3wwr-3g9f-9gc7 (GitHub-reviewed advisory GHSA-3wwr-3g9f-9gc7 lists affected ranges: PyPI asteval >=0 <=1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…