vllm: Malicious model to RCE by torch.load in hf_model_weights_iterator
CVE-2025-24357GHSA-rh4j-5rhw-hr54
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vllm 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI vllm
- Affected
- < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rh4j-5rhw-hr54 lists affected ranges: PyPI vllm >=0 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rh4j-5rhw-hr54 lists affected ranges: PyPI vllm >=0 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2025-24357: 0.89% estimated exploitation activity in the next 30 days; percentile 59.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description The vllm/modelexecutor/weightutils.py implements hfmodelweightsiterator to load the model checkpoint, which is downloaded from huggingface. It use torch.load function and weightsonly parameter is default value False. There is a security warning on https://pytorch.org/docs/stable/generated/torch.load.html, when torch.load load a malicious pickle data it will execute arbitrary code during unpickling. Impact This vulnerability can be exploited to execute arbitrary codes and OS commands in the victim machine who fetch the pretrained repo remotely. Note that most models now use the safetensors format, which is not vulnerable to this issue. References https://pytorch.org/docs/stable/generated/torch.load.html Fix: https://github.com/vllm-project/vllm/pull/12366
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rh4j-5rhw-hr54
- Revision 1 · created ·
Published from osv record GHSA-rh4j-5rhw-hr54
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24357 Advisory: vllm: Malicious model to RCE by torch.load in hf_model_weights_iterator IDs: CVE-2025-24357, GHSA-rh4j-5rhw-hr54 Record: https://patchnext.com/advisories/cve-2025-24357 (revision 2, source checked 26 Oct 2026, 13:32 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vllm 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI vllm: affected < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - `python -m pip show vllm`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vllm. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rh4j-5rhw-hr54 (OSV record GHSA-rh4j-5rhw-hr54 lists affected ranges: PyPI vllm >=0 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-rh4j-5rhw-hr54 (GitHub-reviewed advisory GHSA-rh4j-5rhw-hr54 lists affected ranges: PyPI vllm >=0 <0.7.0) Commands are suggestions: review each one before running it.
Loading voting…