Updatecli exposes Maven credentials in console output
CVE-2025-24355GHSA-v34r-vj4r-38j6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/updatecli/updatecli 0.93.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/updatecli/updatecli
- Affected
- < 0.93.0
- Fixed in
- 0.93.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v34r-vj4r-38j6 lists affected ranges: Go github.com/updatecli/updatecli >=0 <0.93.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.1 · CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2025-24355: 0.22% estimated exploitation activity in the next 30 days; percentile 13.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Private maven repository credentials leaked in application logs in case of unsuccessful retrieval operation. Details During the execution of an updatecli pipeline which contains a maven source configured with basic auth credentials, the credentials are being leaked in the application execution logs in case of failure. Credentials are properly sanitized when the operation is successful but not when for whatever reason there is a failure in the maven repository .e.g. wrong coordinates provided, not existing artifact or version. PoC The documentation currently state to provide user credentials as basic auth inside the repository field. e.g. Logs are sanitized properly in case of a successful operation: but leaks credentials in case the GAV coordinates are wrong (misspelled package name or missing): Impact User credentials/token used to authenticate against a private maven repository can be leaked in clear-text in console or CI logs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v34r-vj4r-38j6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24355 Advisory: Updatecli exposes Maven credentials in console output IDs: CVE-2025-24355, GHSA-v34r-vj4r-38j6 Record: https://patchnext.com/advisories/cve-2025-24355 (revision 1, source checked 26 Oct 2026, 15:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/updatecli/updatecli 0.93.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/updatecli/updatecli: affected < 0.93.0; fixed in 0.93.0 ## Suggested inspection (read-only) - Go github.com/updatecli/updatecli: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/updatecli/updatecli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v34r-vj4r-38j6 (GitHub-reviewed advisory GHSA-v34r-vj4r-38j6 lists affected ranges: Go github.com/updatecli/updatecli >=0 <0.93.0) Commands are suggestions: review each one before running it.
Loading voting…