Skip to content

← Actionable
Medium, CVSS 5.0amended

Directus allows privilege escalation using Share feature

CVE-2025-24353GHSA-pmf4-v838-29hg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 11.2.0; @directus/app 13.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.0 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
EPSS
  • CVE-2025-24353: 0.40% estimated exploitation activity in the next 30 days; percentile 33.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When sharing an item, user can specify an arbitrary role. It allows user to use a higher-privileged role to see fields that otherwise the user should not be able to see. Details Specifying role on share should be available only for admins. The current flow has a security flaw. Each other role should allow to share only in the context of the same role. As there is no role hierarchy in Directus, it is impossible to tell which role is higher or lower, so only admins should be able to specify the role for share. Optionally, instead of specifying a role, shareer should be able to specify which fields (limited to fields shareer sees) are available on shared item. Similarily to import. shareer - a person that creates a share link to item PoC 1. Create a collection with a secret field. 2. Create role A that sees the secret field 3. Create role B that does not see the secret field, but can use share feature. 4. Create item with secret field filled. 5. Use account with role B to share…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pmf4-v838-29hg

  2. Revision 1 · created ·

    Published from osv record GHSA-pmf4-v838-29hg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24353

Advisory: Directus allows privilege escalation using Share feature
IDs: CVE-2025-24353, GHSA-pmf4-v838-29hg
Record: https://patchnext.com/advisories/cve-2025-24353 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 11.2.0; @directus/app 13.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 11.2.0; fixed in 11.2.0
- npm @directus/app: affected < 13.3.1; fixed in 13.3.1

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls @directus/app --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus, @directus/app.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pmf4-v838-29hg (OSV record GHSA-pmf4-v838-29hg lists affected ranges: npm directus >=0 =0 <13.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pmf4-v838-29hg (GitHub-reviewed advisory GHSA-pmf4-v838-29hg lists affected ranges: npm directus >=0 =0 <13.3.1)

Commands are suggestions: review each one before running it.

Loading voting…