resolv vulnerable to DoS via insufficient DNS domain name length validation
CVE-2025-24294GHSA-xh69-987w-hrp8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (resolv 0.6.2, 0.3.1, 0.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems resolv
- Affected
- < 0.2.3>= 0.4.0, < 0.6.2>= 0.3.0, < 0.3.1
- Fixed in
- 0.2.3, 0.3.1, 0.6.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xh69-987w-hrp8 lists affected ranges: RubyGems resolv >=0 =0.4.0 =0.3.0 <0.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2025-24294: 0.66% estimated exploitation activity in the next 30 days; percentile 51.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A denial of service vulnerability has been discovered in the resolv gem bundled with Ruby. Details The vulnerability is caused by an insufficient check on the length of a decompressed domain name within a DNS packet. An attacker can craft a malicious DNS packet containing a highly compressed domain name. When the resolv library parses such a packet, the name decompression process consumes a large amount of CPU resources, as the library does not limit the resulting length of the name. This resource consumption can cause the application thread to become unresponsive, resulting in a Denial of Service condition. Affected Version The vulnerability affects the resolv gem bundled with the following Ruby series: Ruby 3.2 series: resolv version 0.2.2 and earlier Ruby 3.3 series: resolv version 0.3.0 Ruby 3.4 series: resolv version 0.6.1 and earlier Credits Thanks to Manu for discovering this issue. History Originally published at 2025-07-08 07:00:00 (UTC)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xh69-987w-hrp8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24294 Advisory: resolv vulnerable to DoS via insufficient DNS domain name length validation IDs: CVE-2025-24294, GHSA-xh69-987w-hrp8 Record: https://patchnext.com/advisories/cve-2025-24294 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: resolv 0.6.2, 0.3.1, 0.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems resolv: affected < 0.2.3; >= 0.4.0, < 0.6.2; >= 0.3.0, < 0.3.1; fixed in 0.2.3, 0.3.1, 0.6.2 ## Suggested inspection (read-only) - RubyGems resolv: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on resolv. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xh69-987w-hrp8 (GitHub-reviewed advisory GHSA-xh69-987w-hrp8 lists affected ranges: RubyGems resolv >=0 =0.4.0 =0.3.0 <0.3.1) Commands are suggestions: review each one before running it.
Loading voting…