Flask-AppBuilder Observable Response Discrepancy
CVE-2025-24023GHSA-p8q5-cvwx-wvwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (flask-appbuilder 4.5.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI flask-appbuilder
- Affected
- < 4.5.3
- Fixed in
- 4.5.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p8q5-cvwx-wvwp lists affected ranges: PyPI flask-appbuilder >=0 <4.5.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p8q5-cvwx-wvwp lists affected ranges: PyPI flask-appbuilder >=0 <4.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2025-24023: 0.33% estimated exploitation activity in the next 30 days; percentile 26.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact User enumeration in database authentication in Flask-AppBuilder <= 4.5.3 and werkzeug = 3.0.0. Allows for a non authenticated user to enumerate existing usernames by timing the response time from the server when brute forcing requests to login. Patches Upgrade to flask-appbuilder=4.5.3 Workarounds Downgrade werkzeug to <3.0.0 References Are there any links users can visit to find out more?
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p8q5-cvwx-wvwp
- Revision 1 · created ·
Published from osv record GHSA-p8q5-cvwx-wvwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24023 Advisory: Flask-AppBuilder Observable Response Discrepancy IDs: CVE-2025-24023, GHSA-p8q5-cvwx-wvwp Record: https://patchnext.com/advisories/cve-2025-24023 (revision 2, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: flask-appbuilder 4.5.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI flask-appbuilder: affected < 4.5.3; fixed in 4.5.3 ## Suggested inspection (read-only) - `python -m pip show flask-appbuilder`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on flask-appbuilder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p8q5-cvwx-wvwp (OSV record GHSA-p8q5-cvwx-wvwp lists affected ranges: PyPI flask-appbuilder >=0 <4.5.3 (fixed)) - Verified: https://github.com/advisories/GHSA-p8q5-cvwx-wvwp (GitHub-reviewed advisory GHSA-p8q5-cvwx-wvwp lists affected ranges: PyPI flask-appbuilder >=0 <4.5.3) Commands are suggestions: review each one before running it.
Loading voting…