Authenticated Stored XSS in YesWiki
CVE-2025-24018GHSA-w59h-3x3q-3p6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist yeswiki/yeswiki
- Affected
- <= 4.4.5
- Fixed in
- 4.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w59h-3x3q-3p6j lists affected ranges: Packagist yeswiki/yeswiki >=0 <=4.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2025-24018: 0.42% estimated exploitation activity in the next 30 days; percentile 36.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Authenticated Stored XSS in YesWiki <= 4.4.5 Summary It is possible for an authenticated user with rights to edit/create a page or comment to trigger a stored XSS which will be reflected on any page where the resource is loaded. This Proof of Concept has been performed using the followings: - YesWiki v4.4.5 (doryphore-dev branch, latest) - Docker environnment (docker/docker-compose.yml) - Docker v27.5.0 - Default installation Details The vulnerability makes use of the content edition feature and more specifically of the {{attach}} component allowing users to attach files/medias to a page. When a file is attached using the {{attach}} component, if the resource contained in the file attribute doesn't exist, then the server will generate a file upload button containing the filename. This part of the code is managed in tools/attach/libs/attach.lib.php and the faulty function is showFileNotExits(). The file name attribute is not properly sanitized when returned to the client, therefore…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w59h-3x3q-3p6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24018 Advisory: Authenticated Stored XSS in YesWiki IDs: CVE-2025-24018, GHSA-w59h-3x3q-3p6j Record: https://patchnext.com/advisories/cve-2025-24018 (revision 1, source checked 26 Oct 2026, 14:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist yeswiki/yeswiki: affected <= 4.4.5; fixed in 4.5.0 ## Suggested inspection (read-only) - Packagist yeswiki/yeswiki: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on yeswiki/yeswiki. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w59h-3x3q-3p6j (GitHub-reviewed advisory GHSA-w59h-3x3q-3p6j lists affected ranges: Packagist yeswiki/yeswiki >=0 <=4.4.5) Commands are suggestions: review each one before running it.
Loading voting…