Wazuh server vulnerable to remote code execution
CVE-2025-24016GHSA-hcrc-79hj-m3qh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/wazuh/wazuh 4.9.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 4.4.0, < 4.9.1
- Fixed in
- 4.9.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hcrc-79hj-m3qh lists affected ranges: Go github.com/wazuh/wazuh >=4.4.0 <4.9.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- CISA Known Exploited Vulnerabilities Catalog
CISA added CVE-2025-24016 to the Known Exploited Vulnerabilities catalog on 2025-06-10.
VerifiedObserved Listed in the CISA KEV JSON feed (dateAdded 2025-06-10).
Severity and exploitation
- Exploitation
- Confirmed: listed in the CISA Known Exploited Vulnerabilities catalog.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:H/E:H
- EPSS
- CVE-2025-24016: 93.84% estimated exploitation activity in the next 30 days; percentile 99.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An unsafe deserialization vulnerability allows for remote code execution on Wazuh servers. The vulnerability can be triggered by anybody with API access (compromised dashboard or Wazuh servers in the cluster) or, in certain configurations, even by a compromised agent. Details DistributedAPI parameters are a serialized as JSON and deserialized using aswazuhobject (in framework/wazuh/core/cluster/common.py). If an attacker manages to inject an unsanitized dictionary in DAPI request/response, they can forge an unhandled exception (unhandledexc) to evaluate arbitrary python code. Using the server API, it quite easy to trigger. For example, using the runas endpoint (implemented by runaslogin in api/api/controllers/securitycontroller.py): the authcontext argument is completely controlled by the attacker, and is forwarded to the master server to handle. By sending a malicious runas request to a worker server, it is possible to execute code on the master server. It is also possible…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hcrc-79hj-m3qh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-24016 Advisory: Wazuh server vulnerable to remote code execution IDs: CVE-2025-24016, GHSA-hcrc-79hj-m3qh Record: https://patchnext.com/advisories/cve-2025-24016 (revision 1, source checked 26 Oct 2026, 15:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: confirmed: listed in the CISA Known Exploited Vulnerabilities catalog. Vendor response: Vendor fix available; fixed versions by package: github.com/wazuh/wazuh 4.9.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/wazuh/wazuh: affected >= 4.4.0, < 4.9.1; fixed in 4.9.1 ## Suggested inspection (read-only) - Go github.com/wazuh/wazuh: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/wazuh/wazuh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hcrc-79hj-m3qh (GitHub-reviewed advisory GHSA-hcrc-79hj-m3qh lists affected ranges: Go github.com/wazuh/wazuh >=4.4.0 <4.9.1) - Verified: https://www.cisa.gov/known-exploited-vulnerabilities-catalog (CISA added CVE-2025-24016 to the Known Exploited Vulnerabilities catalog on 2025-06-10.) Commands are suggestions: review each one before running it.
Loading voting…