Skip to content

← Actionable
Medium, CVSS 5.3

Missing validation of header name and value in codeigniter4/framework

CVE-2025-24013GHSA-x5mq-jjr3-vmx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (codeigniter4/framework 4.5.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2025-24013: 0.51% estimated exploitation activity in the next 30 days; percentile 43.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Lack of proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. Patches Upgrade to v4.5.8 or later. Workarounds Validate HTTP header keys and/or values if using user-supplied values before passing them to Header class. Differences from CVE-2023-29197 1. Affected Software: CVE-2023-29197 specifically addresses a vulnerability in the guzzlehttp/psr7 library. The reported issue in this Security Advisory is within the CodeIgniter4 framework and does not depend on or use the guzzlehttp/psr7 library. 2. Root Cause and Implementation: The vulnerability reported arises from an issue in the Header class…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x5mq-jjr3-vmx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24013

Advisory: Missing validation of header name and value in codeigniter4/framework
IDs: CVE-2025-24013, GHSA-x5mq-jjr3-vmx6
Record: https://patchnext.com/advisories/cve-2025-24013 (revision 1, source checked 26 Oct 2026, 14:29 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: codeigniter4/framework 4.5.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist codeigniter4/framework: affected < 4.5.8; fixed in 4.5.8

## Suggested inspection (read-only)
- Packagist codeigniter4/framework: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on codeigniter4/framework.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x5mq-jjr3-vmx6 (GitHub-reviewed advisory GHSA-x5mq-jjr3-vmx6 lists affected ranges: Packagist codeigniter4/framework >=0 <4.5.8)

Commands are suggestions: review each one before running it.

Loading voting…