Skip to content

← Actionable
Medium, CVSS 6.5amended

Websites were able to send any requests to the development server and read the response in vite

CVE-2025-24010GHSA-vg6x-rcgg-rjx6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vite 6.0.9, 5.4.12, 4.5.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm vite

    Affected
    >= 6.0.0, <= 6.0.8>= 5.0.0, <= 5.4.11<= 4.5.5
    Fixed in
    4.5.6, 5.4.12, 6.0.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2025-24010: 0.30% estimated exploitation activity in the next 30 days; percentile 22.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Vite allowed any websites to send any requests to the development server and read the response due to default CORS settings and lack of validation on the Origin header for WebSocket connections. [!WARNING] This vulnerability even applies to users that only run the Vite dev server on the local machine and does not expose the dev server to the network. Upgrade Path Users that does not match either of the following conditions should be able to upgrade to a newer version of Vite that fixes the vulnerability without any additional configuration. - Using the backend integration feature - Using a reverse proxy in front of Vite - Accessing the development server via a domain other than localhost or .localhost - Using a plugin / framework that connects to the WebSocket server on their own from the browser Using the backend integration feature If you are using the backend integration feature and not setting server.origin, you need to add the origin of the backend server to the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vg6x-rcgg-rjx6

  2. Revision 1 · created ·

    Published from osv record GHSA-vg6x-rcgg-rjx6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-24010

Advisory: Websites were able to send any requests to the development server and read the response in vite
IDs: CVE-2025-24010, GHSA-vg6x-rcgg-rjx6
Record: https://patchnext.com/advisories/cve-2025-24010 (revision 2, source checked 26 Oct 2026, 12:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vite 6.0.9, 5.4.12, 4.5.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vite: affected >= 6.0.0, <= 6.0.8; >= 5.0.0, <= 5.4.11; <= 4.5.5; fixed in 4.5.6, 5.4.12, 6.0.9

## Suggested inspection (read-only)
- `npm ls vite --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vite.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vg6x-rcgg-rjx6 (OSV record GHSA-vg6x-rcgg-rjx6 lists affected ranges: npm vite >=6.0.0 =5.0.0 =0 <4.5.6 (fixed))
- Verified: https://github.com/advisories/GHSA-vg6x-rcgg-rjx6 (GitHub-reviewed advisory GHSA-vg6x-rcgg-rjx6 lists affected ranges: npm vite >=6.0.0 =5.0.0 =0 <=4.5.5)

Commands are suggestions: review each one before running it.

Loading voting…