Fleet doesn’t validate a server’s certificate when connecting through SSH
CVE-2025-23390GHSA-xgpc-q899-67p8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/fleet 0.12.2, 0.11.7, 0.10.12), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.9.0-rc.1, < 0.10.12>= 0.11.0, < 0.11.7>= 0.12.0, < 0.12.2
- Fixed in
- 0.11.7, 0.10.12, 0.12.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xgpc-q899-67p8 lists affected ranges: Go github.com/rancher/fleet >=0.9.0-rc.1 =0.11.0 =0.12.0 <0.12.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2025-23390: 0.19% estimated exploitation activity in the next 30 days; percentile 8.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability has been identified within Fleet where, by default, Fleet will automatically trust a remote server’s certificate when connecting through SSH if the certificate isn’t set in the knownhosts file. This could allow the execution of a man-in-the-middle (MitM) attack against Fleet. In case the server that is being connected to has a trusted entry in the knownhosts file, then Fleet will correctly check the authenticity of the presented certificate. Please consult the associated MITRE ATT&CK - Technique - Adversary-in-the-Middle for further information about this category of attack. Patches Patched versions include releases v0.10.12, v0.11.7 and v0.12.2. The fix involves some key areas with the following changes: - Git latest commit fetcher sources knownhosts entries from the following locations, in decreasing order of priority: 1. Secret referenced in a GitRepo’s clientSecretName field; 2. If no secret is referenced, in a gitcredential secret located in the GitRepo’s…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xgpc-q899-67p8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23390 Advisory: Fleet doesn’t validate a server’s certificate when connecting through SSH IDs: CVE-2025-23390, GHSA-xgpc-q899-67p8 Record: https://patchnext.com/advisories/cve-2025-23390 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/fleet 0.12.2, 0.11.7, 0.10.12. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/fleet: affected >= 0.9.0-rc.1, < 0.10.12; >= 0.11.0, < 0.11.7; >= 0.12.0, < 0.12.2; fixed in 0.11.7, 0.10.12, 0.12.2 ## Suggested inspection (read-only) - Go github.com/rancher/fleet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/fleet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xgpc-q899-67p8 (GitHub-reviewed advisory GHSA-xgpc-q899-67p8 lists affected ranges: Go github.com/rancher/fleet >=0.9.0-rc.1 =0.11.0 =0.12.0 <0.12.2) Commands are suggestions: review each one before running it.
Loading voting…