Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login
CVE-2025-23389GHSA-mq23-vvg7-xfm4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.8.0, < 2.8.13>= 2.9.0, < 2.9.7>= 2.10.0, < 2.10.3
- Fixed in
- 2.9.7, 2.8.13, 2.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mq23-vvg7-xfm4 lists affected ranges: Go github.com/rancher/rancher >=2.8.0 =2.9.0 =2.10.0 <2.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L
- EPSS
- CVE-2025-23389: 0.48% estimated exploitation activity in the next 30 days; percentile 41.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A vulnerability in Rancher has been discovered, leading to a local user impersonation through SAML Authentication on first login. The issue occurs when a SAML authentication provider (AP) is configured (e.g. Keycloak). A newly created AP user can impersonate any user on Rancher by manipulating cookie values during their initial login to Rancher. This vulnerability could also be exploited if a Rancher user (present on the AP) is removed, either manually or automatically via the User Retention feature with delete-inactive-user-after. More precisely, Rancher validates only a subset of input from the SAML assertion request; however, it trusts and uses values that are not properly validated. An attacker could then configure the samlRancherUserID cookie and the samlRancherAction cookie so that the user principal from the AP will be added to the user specified by the attacker (from samlRancherUserID). Rancher can then be deceived by setting samlRancherUserID to the admin's user ID…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mq23-vvg7-xfm4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23389 Advisory: Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login IDs: CVE-2025-23389, GHSA-mq23-vvg7-xfm4 Record: https://patchnext.com/advisories/cve-2025-23389 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.8.0, < 2.8.13; >= 2.9.0, < 2.9.7; >= 2.10.0, < 2.10.3; fixed in 2.9.7, 2.8.13, 2.10.3 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mq23-vvg7-xfm4 (GitHub-reviewed advisory GHSA-mq23-vvg7-xfm4 lists affected ranges: Go github.com/rancher/rancher >=2.8.0 =2.9.0 =2.10.0 <2.10.3) Commands are suggestions: review each one before running it.
Loading voting…