Rancher allows an unauthenticated stack overflow in /v3-public/authproviders API
CVE-2025-23388GHSA-xr9q-h9c7-xw8q
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 2.8.0, < 2.8.13>= 2.9.0, < 2.9.7>= 2.10.0, < 2.10.3
- Fixed in
- 2.9.7, 2.8.13, 2.10.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xr9q-h9c7-xw8q lists affected ranges: Go github.com/rancher/rancher >=2.8.0 =2.9.0 =2.10.0 <2.10.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
- EPSS
- CVE-2025-23388: 0.60% estimated exploitation activity in the next 30 days; percentile 48.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An unauthenticated stack overflow crash, leading to a denial of service (DoS), was identified in Rancher’s /v3-public/authproviders public API endpoint. A malicious user could submit data to the API which would cause the Rancher server to crash, but no malicious or incorrect data would actually be written in the API. The downstream clusters, i.e., the clusters managed by Rancher, are not affected by this issue. This vulnerability affects those using external authentication providers as well as Rancher’s local authentication. Patches The patch includes the removal of unnecessary HTTP methods of the specific API. Patched versions include releases v2.8.13, v2.9.7 and v2.10.3. Workarounds There are no workarounds for this issue. Users are recommended to upgrade, as soon as possible, to a version of Rancher Manager that contains the fix. References If you have any questions or comments about this advisory: - Reach out to the SUSE Rancher Security team for security related…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-xr9q-h9c7-xw8q
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-23388 Advisory: Rancher allows an unauthenticated stack overflow in /v3-public/authproviders API IDs: CVE-2025-23388, GHSA-xr9q-h9c7-xw8q Record: https://patchnext.com/advisories/cve-2025-23388 (revision 1, source checked 26 Oct 2026, 15:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/rancher/rancher: affected >= 2.8.0, < 2.8.13; >= 2.9.0, < 2.9.7; >= 2.10.0, < 2.10.3; fixed in 2.9.7, 2.8.13, 2.10.3 ## Suggested inspection (read-only) - Go github.com/rancher/rancher: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/rancher/rancher. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xr9q-h9c7-xw8q (GitHub-reviewed advisory GHSA-xr9q-h9c7-xw8q lists affected ranges: Go github.com/rancher/rancher >=2.8.0 =2.9.0 =2.10.0 <2.10.3) Commands are suggestions: review each one before running it.
Loading voting…