Skip to content

← Actionable
Medium, CVSS 5.3

Rancher's SAML-based login via CLI can be denied by unauthenticated users

CVE-2025-23387GHSA-5qmp-9x47-92q8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2025-23387: 0.59% estimated exploitation activity in the next 30 days; percentile 48.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A vulnerability has been identified within Rancher where it is possible for an unauthenticated user to list all CLI authentication tokens and delete them before the CLI is able to get the token value. This effectively prevents users from logging in via the CLI when using rancher token as the execution command (instead of the token directly being in the kubeconfig). Note that this token is not the kubeconfig token and if an attacker is able to intercept it they can't use it to impersonate a real user since it is encrypted. This happens because for SAML-based authentication providers, the login flow from the CLI works by generating a link to be pasted in the browser, and then polling every 10 seconds for the /v3-public/authTokens/<token name endpoint. The <token name is randomly generated by the CLI. Once the login flow succeeds, Rancher creates an auth token (with an encrypted token value). The CLI then deletes the authToken. Rancher deployments using only the local…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5qmp-9x47-92q8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23387

Advisory: Rancher's SAML-based login via CLI can be denied by unauthenticated users
IDs: CVE-2025-23387, GHSA-5qmp-9x47-92q8
Record: https://patchnext.com/advisories/cve-2025-23387 (revision 1, source checked 26 Oct 2026, 15:09 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/rancher/rancher 2.10.3, 2.9.7, 2.8.13. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/rancher/rancher: affected >= 2.8.0, < 2.8.13; >= 2.9.0, < 2.9.7; >= 2.10.0, < 2.10.3; fixed in 2.9.7, 2.8.13, 2.10.3

## Suggested inspection (read-only)
- Go github.com/rancher/rancher: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/rancher/rancher.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5qmp-9x47-92q8 (GitHub-reviewed advisory GHSA-5qmp-9x47-92q8 lists affected ranges: Go github.com/rancher/rancher >=2.8.0 =2.9.0 =2.10.0 <2.10.3)

Commands are suggestions: review each one before running it.

Loading voting…