Skip to content

← Actionable
High, CVSS 8.1

Wildfly Elytron integration susceptible to brute force attacks via CLI

CVE-2025-23368GHSA-qhp6-6p8p-2rqh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.core:wildfly-elytron-integration 32.0.0.Beta3, 31.0.3.Final), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2025-23368: 0.89% estimated exploitation activity in the next 30 days; percentile 59.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A flaw was found in Wildfly Elytron integration. The component does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame, making it more susceptible to brute force attacks via CLI. Patches The default behaviour has been changed in WildFly Core 31.0.3.Final, and 32.0.0.Beta3 - the first version is used by WildFly 39.0.1.Final and the second will be included in WildFly 40. Workarounds No direct workaround. Monitoring network traffic / blocking suspicious traffic may help. References https://www.cve.org/CVERecord?id=CVE-2025-23368 https://issues.redhat.com/browse/WFCORE-7192 Acknowledgements We would like to thank Claudia Bartolini (TIM S.p.A), Marco Ventura (TIM S.p.A), and Massimiliano Brolli (TIM S.p.A) for reporting this issue.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qhp6-6p8p-2rqh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2025-23368

Advisory: Wildfly Elytron integration susceptible to brute force attacks via CLI
IDs: CVE-2025-23368, GHSA-qhp6-6p8p-2rqh
Record: https://patchnext.com/advisories/cve-2025-23368 (revision 1, source checked 26 Oct 2026, 16:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.wildfly.core:wildfly-elytron-integration 32.0.0.Beta3, 31.0.3.Final. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.wildfly.core:wildfly-elytron-integration: affected >= 32.0.0.Beta1, < 32.0.0.Beta3; < 31.0.3.Final; fixed in 32.0.0.Beta3, 31.0.3.Final

## Suggested inspection (read-only)
- Maven org.wildfly.core:wildfly-elytron-integration: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.wildfly.core:wildfly-elytron-integration.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qhp6-6p8p-2rqh (GitHub-reviewed advisory GHSA-qhp6-6p8p-2rqh lists affected ranges: Maven org.wildfly.core:wildfly-elytron-integration >=32.0.0.Beta1 =0 <31.0.3.Final)

Commands are suggestions: review each one before running it.

Loading voting…